2

The title says it all, i am going insane... tried all of that and none where working

  • disable firewall
  • sudo pfctl -s all
  • restart
  • fix IP Address
  • changed Router to hotspot to get different IPS
  • disabled all launch-agents
  • NO VPN installed
  • ping @ mac-name.local

did a sudo tcpdump 'icmp[icmptype] = icmp-echo or icmp[icmptype] = icmp-echoreply' which gives me 11:40:38.011922 IP 192.168.0.137 > 192.168.0.80: ICMP echo request, id 28937, seq 814, length 64

and as far as i understood, that means the request is coming in, but somehow blocked. I can ping my other macbook from the machine i am trying to access ping 192.168.0.137 PING 192.168.0.137 (192.168.0.137): 56 data bytes 64 bytes from 192.168.0.137: icmp_seq=0 ttl=64 time=48.151 ms I can even ping the other macbook from windows, i can also ping to a windows laptop.

The one i need, is not pingable or accessible from anywhere. Totally running out of ideas, tried the log (wifi.log/system.log), could not find anything useful in there. Running out of ideas, please help :)

i also tried starting an angular app via: ng serve --host 0.0.0.0 --disable-host-check also no accessible

Thank you

Update 03/June/2021

I am able to access my laptop now, but only via IPv6. Since i needed it to access my local web server, i just simply added a local entry in my /private/etc/hosts which looks like: 2a02:908:e845:5e80:1094:6481:a769:497d mymac.de

That at least lets me access my machine in the browser and configure specific settings in chrome ( i need camera access and that does not work anymore with http ).

It feels like a massive 'hack' :)

6
  • Do you have Little Snitch or similar installed?
    – jksoegaard
    Jun 1, 2021 at 18:22
  • The fact that tcpdump does not say "mac-name.local" for either IP tells me that tcpdump is unable to reverse lookup the name for the address. Perhaps it can't do the forward resolved for the same reason. I posted an answer suggesting one reason, but per comment, it may be a different one.
    – WGroleau
    Jun 1, 2021 at 18:34
  • Why the @ ? With my ping, that is an error.
    – WGroleau
    Jun 1, 2021 at 18:36
  • @WGroleau No, it is definitely not name resolution that is the problem. Reverse lookups working or not working has no effect on ping. If forward resolution did not work, tcpdump wouldn't have shown the packet. Definitely not DNS here.
    – jksoegaard
    Jun 1, 2021 at 19:11
  • Name resolution has no effect on ping, but DNS does have an effect on tcpdump. OP's example shows that is not happening for him.
    – WGroleau
    Jun 1, 2021 at 19:26

2 Answers 2

1

I know its an old post, but I was facing that issue all over again and today I finally found the solution.

The first comment from @jksoegaard seemed to be the correct hint. After installing a software called KnockKnock I figured out that I have three applications (one of them called 'cpfw.kext', which is Check Point Software and that is VPN software) Installed as Kernel-Extensions. I simply deleted those files (cpfw.kext, acsock.kext, HoRNDIS.kext), rebooted and after that my mac was accessible again from any pc in the same network.

Here you see a picture from my linux machine connecting to the mac via VNC :-) (Plus the deleted files..)

enter image description here

2
  • Where did you find these files, in which directory?
    – nohillside
    May 9, 2022 at 6:10
  • @nohillside usually, they are located under /Library/Extensions
    – burnedikt
    Jan 7, 2023 at 21:57
-1

The source machine probably has the router as a caching DNS server, which goes to the DNS network looking for “who handles *.local addresses?” And gets no answer.

1
  • No, that cannot be the cause - if DNS was the problem, you wouldn't see the ICMP packet in the tcpdump.
    – jksoegaard
    Jun 1, 2021 at 18:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .