0

I have a MBP connected to an external monitor.

When I'm on the laptop (a window on the laptop is active) and I swipe right or left with my 3 fingers to switch to another full screen app on the laptop, a window on the external display is activated! so If I start typing, characters will be shown on the other window on the external monitor, not on the app I have switched to on my laptop.

Is there a way to fix this so that Mac does not automatically jump to another window on the monitor when I switch on the laptop?

Specs:

  • MBP 15" 2019
  • Big Sur 11.3.1

Update: Strangely, this only happens with iTerm when it is in "split-screen" mode with another app (Slack). When I make iTerm full-screen this does not happen.

Update2: Mission control settings: enter image description here

2
  • 1
    See System Prefs > Mission Control & let us know which are checked/unchecked. Post a pic if it's easier.
    – Tetsujin
    Commented Jun 1, 2021 at 9:22
  • 1
    Sorry, I've never used spilt screen [& I even avoid fullscreen like the plague] so I can't help, I'm afraid.
    – Tetsujin
    Commented Jun 1, 2021 at 11:02

0

You must log in to answer this question.

Browse other questions tagged .