1

I'm running macOS 11.3.1 on my 2013 MacBook Air and wanted to remove my Bootcamp and reclaim the space. Had around 40GB free on my macOS partition and the Bootcamp one was 50GB. So I ran the Bootcamp Assistant to remove the partition - thing is, it froze mid-process and the computer stopped responding, even the curson stopped moving. So I powered it off with the button, powered it on again and now there is neither the Bootcamp partition nor its space anywhere to be seen as it did not get reclaimed by the macOS partition. Diskutil outputs:

/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *251.0 GB   disk0
   1:                        EFI ⁨EFI⁩                     209.7 MB   disk0s1
   2:                 Apple_APFS ⁨Container disk1⁩         250.8 GB   disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +200.8 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume ⁨Macintosh HD – dane⁩     133.4 GB   disk1s1
   2:                APFS Volume ⁨Preboot⁩                 389.2 MB   disk1s2
   3:                APFS Volume ⁨Recovery⁩                622.2 MB   disk1s3
   4:                APFS Volume ⁨VM⁩                      2.1 GB     disk1s4
   5:                APFS Volume ⁨Macintosh HD⁩            15.4 GB    disk1s5
   6:              APFS Snapshot ⁨com.apple.os.update-...⁩ 15.4 GB    disk1s5s1

and diskutil cs list:

No CoreStorage logical volume groups found

The 50GB isn't visible in the GUI diskutil either. How can I reclaim that space?

EDIT: also, two more outputs:

straightfw@MacBook-Air ~ % diskutil apfs list

APFS Container (1 found)
|
+-- Container disk1 C02F9F4E-46B4-4E4F-8004-169895879D08
    ====================================================
    APFS Container Reference:     disk1
    Size (Capacity Ceiling):      200790749184 B (200.8 GB)
    Capacity In Use By Volumes:   159519363072 B (159.5 GB) (79.4% used)
    Capacity Not Allocated:       41271386112 B (41.3 GB) (20.6% free)
    |
    +-< Physical Store disk0s2 8A1262CF-40B9-4FE7-8EA8-97885D518F3C
    |   -----------------------------------------------------------
    |   APFS Physical Store Disk:   disk0s2
    |   Size:                       250790436864 B (250.8 GB)
    |
    +-> Volume disk1s1 9060519F-8CE4-3240-A7AF-9D2EB92F73CE
    |   ---------------------------------------------------
    |   APFS Volume Disk (Role):   disk1s1 (Data)
    |   Name:                      Macintosh HD – dane (Case-insensitive)
    |   Mount Point:               /System/Volumes/Data
    |   Capacity Consumed:         139794690048 B (139.8 GB)
    |   Sealed:                    No
    |   FileVault:                 Yes (Unlocked)
    |
    +-> Volume disk1s2 0E2C2B5E-0C5E-4E80-B48F-20D934BBA8B9
    |   ---------------------------------------------------
    |   APFS Volume Disk (Role):   disk1s2 (Preboot)
    |   Name:                      Preboot (Case-insensitive)
    |   Mount Point:               /System/Volumes/Preboot
    |   Capacity Consumed:         389234688 B (389.2 MB)
    |   Sealed:                    No
    |   FileVault:                 No
    |
    +-> Volume disk1s3 85F0821D-53AB-42D9-BA07-AF72EC58AA99
    |   ---------------------------------------------------
    |   APFS Volume Disk (Role):   disk1s3 (Recovery)
    |   Name:                      Recovery (Case-insensitive)
    |   Mount Point:               Not Mounted
    |   Capacity Consumed:         622211072 B (622.2 MB)
    |   Sealed:                    No
    |   FileVault:                 No
    |
    +-> Volume disk1s4 B60D2F3C-94D0-4258-A5EB-0A7C92E51C03
    |   ---------------------------------------------------
    |   APFS Volume Disk (Role):   disk1s4 (VM)
    |   Name:                      VM (Case-insensitive)
    |   Mount Point:               /System/Volumes/VM
    |   Capacity Consumed:         3222298624 B (3.2 GB)
    |   Sealed:                    No
    |   FileVault:                 No
    |
    +-> Volume disk1s5 29671E89-9A39-4284-9035-7987D7DC3272
        ---------------------------------------------------
        APFS Volume Disk (Role):   disk1s5 (System)
        Name:                      Macintosh HD (Case-insensitive)
        Mount Point:               /Volumes/Macintosh HD 1
        Capacity Consumed:         15355846656 B (15.4 GB)
        Sealed:                    Broken
        FileVault:                 Yes (Unlocked)
        Encrypted:                 No
        |
        Snapshot:                  A7F7CFDE-537A-4473-A237-B01C0146C2B8
        Snapshot Disk:             disk1s5s1
        Snapshot Mount Point:      /
        Snapshot Sealed:           Yes

and

straightfw@MacBook-Air ~ % diskutil apfs resizeContainer disk0s2 limits

Resize limits for APFS Physical Store partition disk0s2:
  Current Physical Store partition size on map:   250.8 GB (250790436864 Bytes)
  Minimum (constrained by file/snapshot usage):   163.6 GB (163644964864 Bytes)
  Recommended minimum (if used with macOS):       174.4 GB (174382383104 Bytes)
  Maximum (constrained by partition map space):   250.8 GB (250790436864 Bytes)
0

You can try this :

diskutil ap resizecontainer disk1 0b
5
  • Thanks - I get Error: -69743: The new size must be different than the existing size then, though :(
    – Straightfw
    May 31 at 13:17
  • Can you boot in Recovery Mode (CMD+R at boot) then with Disk Utility you select your "Data Volume" and mount it (giving your password) then you select the System Container and do a "First Aid".
    – Jean_JD
    May 31 at 13:41
  • I wonder if the container is smaller than the partition. May 31 at 13:50
  • What do you suppose would happen if first a command was issued to resize to something significantly smaller than 250.8 GB before applying your answer. May 31 at 14:09
  • Jean_JD and @DavidAnderson thanks for the replies, managed to fix it - description in the answer above!
    – Straightfw
    May 31 at 14:37
0

OK, fixed! For posteriority: in the end the fix was to go to the Disk Utility (I used the GUI one) and try creating a new FAT partition. A full-sized one didn't work in my case (There is not enough free space in this APFS Container for this operation. : (-69605)) so I chose 40GB (even though the size selector text box is greyed out you can still use the circle dials on the left hand side).

This caused an error to occur again, this time later in the process (no error code, just "internal error occurred, try again later") but a new 40GB partition still appeared in disk utility (albeit an exFAT one instead of the FAT we choose in the beginning). So I tried removing it through the same partitioning dialog I created it with in disk utility, and then somehow magically my main macOS partition started having full 90GB of free space instead of the 40GB it had before with 50GB floating in the abyss.

So all's good now, thanks for all the other replies!

1
  • There is no magic. First you make the partition with the APFS container smaller, then larger. You did this by temporarily creating an partition with an ExFAT volume. This question has be asked and answered before. May 31 at 15:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .