I installed VMware on my MacBook Air (running OS X Lion) and now want to delete it. I dragged VMware into the trash and tried emptying it, but a popup notes that The operation can’t be completed because the item “VMware Fusion” is in use.

I tried pressing command + option + esc but could not see VMware open. I am confused about how VMware is in use.

3 Answers 3


Try this:

  1. Open Activity Monitor from /Applications/Utilities and change the Show drop down from My Processes to All Processes.

  2. Sort by name and find any processes that have the name VMWare.

  3. Press the Quit Process button and click Force Quit.

For removing the app, I recommend AppZapper.

  • 1
    +1, nice, you beat me to the punch! Other info you might want to see in a related question: apple.stackexchange.com/questions/470/…
    – JW8
    Mar 1, 2012 at 1:01
  • Thanks closing all related processes and then using AppZapper works well.
    – David Faux
    Mar 1, 2012 at 1:45

Here is how you remove VMWare Fusion as referenced here from VMWare: Manually uninstalling VMware Fusion

Fusion 4.x

In Fusion 4.x, there is no uninstaller. Most Fusion files are contained within the application bundle (that is, the Fusion application in /Applications). To uninstall Fusion 4.x, drag the application bundle from the Applications folder to the Trash.

Also, ensure to delete these additional files and folders if they are present.

Note: Depending on the environment, some of these files may not be present. Some files may exist only if Fusion 3 was originally installed on the machine that was later upgraded to Fusion 4.

/Library/Application Support/VMware Fusion /Users/Library/Preferences/VMware Fusion /Library/Preferences/VMware\ Fusion ~/Library/Caches/com.vmware.fusion ~/Library/Application\ Support/VMware\ Fusion ~/Library/Preferences/com.vmware.fusion.LSSharedFileList.plist ~/Library/Preferences/com.vmware.fusion.LSSharedFileList.plist.lockfile ~/Library/Preferences/com.vmware.fusion.plist ~/Library/Preferences/com.vmware.fusion.plist.lockfile ~/Library/Preferences/com.vmware.fusionDaemon.plist ~/Library/Preferences/com.vmware.fusionDaemon.plist.lockfile

Note: In Lion, the Library folder inside your user directory is hidden by default. To access your Library folder:

Click the Finder icon. While holding the Option key, click the Go menu. This reveals your Library folder.


You can run the shell script below. The bash version of the script below will also serve the same purpose.

#!/usr/bin/env bash
# Usage: sudo sh ./uninstall_vmware.sh
remove() {

  echo -ne "Removing \e[1;34m$entry\e[0m... "
  sudo rm -rf "$entry" &> /tmp/uninstall-vmware.log

  if [[ ! -e "$entry" ]]; then
    echo -e "\e[1;32mOK\e[0m"
    echo -e "\e[1;31mFAILED\e[0m"

remove "/Applications/VMware Fusion.app"
remove "/Library/Application Support/VMware"
remove "/Library/Application Support/VMware Fusion"
remove "/Library/Preferences/VMware Fusion"
remove "/private/var/root/Library/Logs/VMware"
remove "/private/var/db/vmware"
remove "/Library/Logs/VMware/"
remove "/private/var/run/vmware"
remove "/private/var/run/VMware Fusion Services.lock"
remove "/private/var/run/VMware Fusion Services.sock"
remove "/private/var/root/Library/Preferences/VMware Fusion"
remove "$HOME/Library/Application Support/VMware Fusion"
remove "$HOME/Library/Caches/com.vmware.fusion"
remove "$HOME/Library/Preferences/VMware Fusion"
remove "$HOME/Library/Logs/VMware"
remove "$HOME/Library/Preferences/VMware Fusion"
remove "$HOME/Library/Preferences/com.vmware.fusion.LSSharedFileList.plist"
remove "$HOME/Library/Preferences/com.vmware.fusion.plist"
remove "$HOME/Library/Preferences/com.vmware.fusionStartMenu.plist"
remove "$HOME/Library/Preferences/com.vmware.fusion.LSSharedFileList.plist"
remove "$HOME/Library/Preferences/com.vmware.fusion.LSSharedFileList.plist.lockfile"
remove "$HOME/Library/Preferences/com.vmware.fusion.plist"
remove "$HOME/Library/Preferences/com.vmware.fusion.plist.lockfile"
remove "$HOME/Library/Preferences/com.vmware.fusionDaemon.plist"
remove "$HOME/Library/Preferences/com.vmware.fusionDaemon.plist.lockfile"
remove "$HOME/Library/Preferences/com.vmware.fusionStartMenu.plist"
remove "$HOME/Library/Preferences/com.vmware.fusionStartMenu.plist.lockfile"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .