0

Two volumes mount when it's in:

enter image description here

enter image description here

so it looks like I partitioned it when I tried to install something on it but "Partition" cannot be clicked.

enter image description here

"Erase" fails on both partitions:

enter image description here

I tried the SD app called "SD Card Formatter" but this also didn't work.

enter image description here

Can I wipe this Micro SD card clean, and is there a way to test it to see if it's usable (I have a lot of issues with it)?

6
  • 2
    It's probably dead. Bin it. There is a long, detailed explanation on Super User - superuser.com/questions/1125282/… - but the short version is, it's probably firmware locked after a write error. This is, to all intents & purposes, irreversible. There's one outside chance - hit Cmd/2 which will show the devices rather than just the partitions & try to Erase the whole card.
    – Tetsujin
    May 27, 2021 at 17:15
  • In disk utility, if you clic on View icon and select Display all disk, then select the SD card and “Erase" is it better?
    – user415185
    May 27, 2021 at 17:55
  • What Tetsujin said is the actual situation. Displaying the Volume and trying to erase it just resulted in "Erase Process has Failed (...) Couldn't Open Device". $30 dollars that I can safely place in the poubelle. May 27, 2021 at 19:24
  • Note that in some cases the partition is locked by some process on the device it is meant to be used on. So if this came out of a camera of some sort you could try and format it in the camera. failing that scenario, yeah bin it. May 28, 2021 at 0:18
  • @SteveChambers - it's part FAT & part ExtFS3 - more likely a failed nix installer than anything from a camera.
    – Tetsujin
    May 28, 2021 at 8:48

1 Answer 1

2

I was ready to follow the suggestions in the comments and put the SD Card in the 🗑.

However, Steve's comment brought up the idea that a camera might be able to format the card that the computer couldn't (even though the card's firmware lock was not a result of using it in a camera).

I tried putting the Micro SD in my Panasonic LX7 but got an error message right away ("please reinsert the memory card"). Then I placed the card in my Sony Nex 5 and the Sony was able to Format the card without a problem.

enter image description here

When I placed the card back into the Mac, it was repaired.

This solved my problem, but I am grateful for the comments that led me in the right direction.

I understand that a solution involving a mirrorless camera might not be accessible to everyone, but I would recommend to not trash SD cards that become locked after write errors, and to try formatting it in various devices that have a Format function.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .