0

I think I am experiencing permission problems on my Mac. I am running an iMac with macOS Big Sur, recently updated to 11.4, though the problem has been around for a while.

There is one application which cannot save an existing file (though it can save a new one). As part of the trouble-shooting process, I logged in as an alternative user, and it seems to work properly. I conclude that it has something to do with who can do what.

I have also saved the file to an external USB flash storage, which is in ExFat format. This is from my normal account. Again this works perfectly, so I conclude that saving on a volume with no specific permissions is OK. I doesn’t work if I save to an external drive formatted with HFS+ or APFS.

This leads me to conclude that the problem is one of permissions, possibly on the ~/Library directory. Comparing permissions on the Home directories, I get:

drwxr-xr-x+ 11 irving     staff    352 27 May 14:32 irving/
drwxr-xr-x@ 97 mark       staff   3104 26 May 09:54 mark/
drwxr-xr-x+ 13 something  staff    416 26 May 09:57 something/

The mark directory is for my normal account, and the only differences I can see are that final symbol (+ or @).

When I run ls -l@d /Users/* I get:

drwxr-xr-x+ 11 irving     staff    352 27 May 15:02 /Users/irving/
drwxr-xr-x@ 97 mark       staff   3104 26 May 09:54 /Users/mark/
    com.apple.metadata:_kTimeMachineNewestSnapshot    50
    com.apple.metadata:_kTimeMachineOldestSnapshot    50
drwxr-xr-x+ 13 something  staff    416 26 May 09:57 /Users/something/

What are the correct permissions for a Home directory, and how can I ensure that they are all set correctly?

Output from ls -l@e /Users/mark*/Downloads/*.lbx:

-rw-r--r--@ 1 mark  staff  1156 21 Mar 09:50 /Users/mark/Downloads/Test Label.lbx
    com.apple.lastuseddate#PS     16
    com.apple.macl    72
    com.apple.metadata:_kMDItemUserTags   42
    com.apple.metadata:kMDLabel_mfabisnytttdleinsb4kkin77y    89
    com.apple.quarantine      29
-rw-r--r--@ 1 mark  staff  1641 13 Apr 17:42 /Users/mark/Downloads/Test2.lbx
    com.apple.lastuseddate#PS     16
    com.apple.macl    72
    com.apple.metadata:_kMDItemUserTags   42
    com.apple.metadata:kMDLabel_mfabisnytttdleinsb4kkin77y    89
-rw-r--r--@ 1 mark  staff  1150 27 May 16:18 /Users/mark/Downloads/test.lbx
    com.apple.lastuseddate#PS     16
    com.apple.macl    72
    com.apple.metadata:kMDLabel_mfabisnytttdleinsb4kkin77y    89tp
13
  • What is the result of ls -l@d /Users/*. For reset permissions on your User Structure you can try this command : diskutil resetuserpermissions / `id -u` – Jean_JD May 27 at 5:23
  • @Jean_JD I have run the command, and the problem persists. – Manngo May 27 at 5:40
  • Ah, so you open a file from ~/Documents and can‘t save it into any directory? What application is this? – nohillside May 27 at 5:58
  • @nohillside I can always save as a new document into any directory. I just can’t save an existing document. The software I’m using doesn’t have a Save As… option, so it’s a matter of moving the file or renaming it. – Manngo May 27 at 6:02
  • Can you please run ls -l@e on one of these files? – nohillside May 27 at 6:17
1

This appears to be the result of a poorly completed Time Machine restore

drwxr-xr-x@ 97 mark       staff   3104 26 May 09:54 /Users/mark/
    com.apple.metadata:_kTimeMachineNewestSnapshot    50
    com.apple.metadata:_kTimeMachineOldestSnapshot    50

You can try this 2 commands for suppress this attributs :

xattr -rd com.apple.metadata:_kTimeMachineNewestSnapshot /Users/mark 

and

xattr -rd com.apple.metadata:_kTimeMachineOldestSnapshot /Users/mark 
4
  • Thanks, I tried that but it doesn’t seem to help. I was getting a lot of Permission denied messages, so I used sudo. I then got a lot of No such file messages. – Manngo May 27 at 6:24
  • You must start by adding the terminal in the system preferences / Security, Privacy / Privacy / Full access to the disk, then restart the terminal and retry. – Jean_JD May 27 at 6:37
  • I’ve just done that. I’m still getting the same messages. – Manngo May 27 at 6:40
  • You can try sudo chflags -R nouchg /Users/mark and retry. If you have always the error message you can try sudo chflags -R noschg /Users/mark – Jean_JD May 27 at 6:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .