0

This may sound a little weird but I'm using spaces on my MacBook (currently latest BigSur version) for a couple years and there are a few behaviour I don't understand.

I usually work with my MacBook + 1 external display. My "main" display is my external display. So I have 1 space on my external display and 3 spaces on my macbook display. Each space has a defined task for me (personally):

  • MacBook Space 1: One Chrome Window containing our Ticket System
  • MacBook Space 2: One Window of Microsoft Outlook 2019 - Mails
  • MacBook Space 3: usually has one Window of Microsoft Outlook 2019 - Events
  • external Display Space 1: I work here :-) Multiple Chrome windows, IDEs, Terminal, etc.

Note: No applications are running in "Fullscreen mode". I always run everything in windowed mode.

Now when restarting my MacBook all window positions and sizes are screwed. When my MacBook is booted again, I have to rearrange all windows every day manually because neither position nor sizes are being "saved".

Is this the typical behaviour? Why is it like this? I mean I do understand that spaces/windows/positions are getting screwed when you connect/disconnect displays, but that is not the case for me. I start my MacBook having the same Monitors plugged in and I shut it down in the same state. I'd like to understand why it is the way it seems to be or ways to work better with spaces.

If you can't follow my thoughts fully, please let me know, I'd try to provide some screenshots.

4
  • 1
    This has been a complaint about window management system in macOS for years. Asking why Apple does something is very difficult to answer. Just out of curiosity: do you need to shutdown your mac?
    – X_841
    May 26 at 7:08
  • That's a good point. I have the checkbox checked on shutdown which says "Reopen windows". I could try to using Sleep instead. Just closing the MacBook doesn't work because I have Power+Display connected with an adapter which would just disconnect the MacBook display.
    – feumw
    May 26 at 7:14
  • Just activate sleep with cmd+ctrl+q (be careful: without the ctrl you will force quit your current app). Afterwards you can also close the lid. Alternatively go to apple logo and click sleep.
    – X_841
    May 26 at 7:20
  • Okay, I gonna try it from now on. Old habbits die hard g
    – feumw
    May 27 at 6:14
1

There has never been any provision in Spaces for one app to be on more than one Space. It's simply outside the design spec.

You can pin an app to a Space but you cannot pin a window to a Space. Quit & relaunch & the windows will all fold into the same Space.
Window sizes should be remembered, but not if they wouldn't fit the display they opened on.

Sleeping the Mac should work, but will be dependant on whether the external display stays 'visible' to the Mac at wake. On Mac Pros here, desktops with multiple external displays, this works just fine. idk how well laptops handle this. Sometimes forcing the display to wake before the Mac succeeds in maintaining the connection.
One additional point - Macs don't really need shutting down or restarting all that frequently. Mine generally get rebooted for OS updates etc, the rest of the time they are awake or asleep. Maybe once a month or so, if I feel things might be getting a little sluggish, I will reboot. I've had Mac that ran a decade with little more than this. One never even slept, it was up 24/7/365 for 10 years with the occasional reboot for updates or a shutdown twice a year for a good clean.

2
  • 1
    I'm happy because it looks like people understand my issue. I will use and try around with sleep now and see if things are getting better. Well, yes, maybe my way of using spaces is not the best but at least for me it's really great feature. I can work so much better on one/two screens using spaces then having 4 external displays. Anyway thank you for that information!
    – feumw
    May 27 at 6:13
  • Oh, for sure. I love Spaces. Been using it since someone invented a 3rd party way of doing it back in the 90s. I've learned to live within its limitations though.
    – Tetsujin
    May 27 at 8:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .