2

I have a Ricoh Aficio MP 2000 printer. I have macOS Big Sur running on a Mac mini. It is possible to connect to the printer and print graphics, web pages, etc. But I have problems to print PDFs with embedded fonts. I always get Error: invalidfont.

I tried the following drivers.

What else could I do?

2 Answers 2

2
+200

From what I can find, the Ricoh MP 2000 is c. 15 years old. PostScript support seems to be an option, rather than as standard.

However, invalidfont is certainly a PostScript error. It frequently occurs in Level 3 PostScript submitted to printers that only handle Level 2.

You could see if it will print a PDF from Adobe Reader or Acrobat using the "Print as Image" print option in those apps. This will RIP (rasterize) the page data on the computer instead of on the printer.

I don't know whether those Ricoh print drivers are capable of switching to PCL. You may need to check all the available options in the print dialog, and see if there's anything relating to fonts, or how the data is sent.

3
  • PostScript seems to be the default for this device, you only get the PPD from Ricoh as a Driver Jun 8, 2021 at 11:02
  • @SebastianSemmler You could try adjusting the PostScript Level in the PPD down to Level 2, if it's not already.
    – benwiggy
    Jun 8, 2021 at 11:52
  • 1
    I got it working. You were right, PostScript is not the default option for the device, the machine has to have a PostScript card installed, which it has not. By searching the printer via the IP and choosing the LPD protocol, I could choose a generic PCL driver and everything worked. Jun 8, 2021 at 12:00
1

From the Finder, select Go > Go to Folder... In the dialog box enter: /Library/Printers/PPDs/Contents/Resources

Open the ppd file for your printer in e.g. TextEdit and change the TTRasterizer setting to None e.g.:

*TTRasterizer Type42 change to *TTRasterizer: None

Save the ppd file. If you’re using the generic ppd file just add the line *TTRasterizer: None after Language level entry.

Install your printer using this new PPD.

4
  • 1
    You could edit the PPD 'in use' at /etc/cups/ppd, without having to reinstall the printer.
    – benwiggy
    May 30, 2021 at 16:55
  • It does not work. I also tried the options TrueImage, Accept68K, Type42. Jun 2, 2021 at 17:54
  • My school has several MP 2000 in use and so far disabling internal rastering of included fonts always solved printing problems. Can you make one of your PDFs available for further inspection? Jun 2, 2021 at 18:03
  • It is every file, where the font is not installed on the machine. Sorry, can't provide a file. I edited the file at /etc/cups/ppd, to be certain to change the right config. @slartibartfast could you provide your ppd for the MP 2000 file? Jun 7, 2021 at 14:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .