0

Operating on a VPN or proxy is fine when I'm browsing and surfing, but certain sites will change the content based on the geographic location associated with the IP address of the VPN/Proxy Server, and several accounts will refuse to log in without multiple tedious verification measures. Something I did must have led to this initially, but I don't know what. What matters is this:

• Using my home Wi-Fi, not a workplace network.

• No problem connecting from any device. Lately, however…

• Previous MacBook Pro would connect successfully, and would show that there was full signal, but…

• Many webpages cannot load unless I activate my browser's Proxy IP or my computer's VPN, and…

• Even email, the App Store, and various internet-connection-reliant applications and services would fail to connect. Being unable to connect to iCloud was probably the most frustrating.

• Despite having migrated to a new MacBook Pro, the error transferred itself along with almost everything else– but the new computer's internet operation worked just fine before any data migration!

I don't experience this with any other device in the house. This is a software-related issue, since it occurs on different hardware running a cloned system.

What locations (within the system, utilities, libraries, etc.) might inspect to identify what exactly is causing this problem? What are some tools that can help diagnose this?

4
  • What kind of VPN do you have installed or configured?
    – not2savvy
    May 24, 2021 at 7:54
  • I have PureVPN. Even if I have it proxy to a different State in the same time zone, it runs better than if I have nothing running. My alternative proxy is the 'VPN' built into Opera web browser and the Opera GX gaming web browser (they call it a 'free VPN' but it's really just a free proxy service with only 3 locations to choose from. I am now testing it at a different location on the same Wi-Fi service and I'm not running either service, and it works just fine, so it might just be something about my computer's connection with my router? But my devices are the only ones that experience it. May 26, 2021 at 0:21
  • 1
    Well, I suspect that your VPN does not properly reset the DNS server setting when turned off. But I don’t know PureVPN, so I can’t make any proposals how to fix it. Check with PureVPN if that is a known issue. You may uninstall it, reset your network settings, then try again from scratch.
    – not2savvy
    May 26, 2021 at 7:58
  • But I am able to do it with just a simple Proxy– nothing involving PureVPN. I'll investigate how to reset the DNS server setting. May 26, 2021 at 21:03

0

You must log in to answer this question.

Browse other questions tagged .