I'm on a MacBook Pro , bought June 2020.

I updated to Big Sur from Catalina 10.15.7 this morning, and the upgrade went OK.

However, since then, it's become slow and unresponsive, beachballing a lot, Finder had problems launching and constantly Application Not Responding.

Finder won't launch very often, if at all.

It's the latest version of Big Sur, 11.3.1, which I've got.

Other problems are that I cannot click on the black Apple Icon to shutdown or restart (sometimes it works, sometimes it doesn't), and apps crash a lot - BBEdit, occasionally Firefox etc. have Application Not Responding.

I tried creating a second user account with admin privileges, same issue there; repaired user permissions for my main admin account.

I did an EtreCheck and had to remove remnants of DiskDrill which I'd tried when I had Catalina.

What solutions would you recommend, I've tried Google-ing but aren't sure what would fix this?

  • Has Spotlight finished indexing & Time machine completed its first backup?
    – Tetsujin
    Commented May 23, 2021 at 15:48
  • How many different apps will suffer a beachball / non-responsive state in a 7 day period?
    – bmike
    Commented May 23, 2021 at 16:47
  • I found after rebooting "again" then it got better than just straight beachballs...
    – rogerdpack
    Commented Apr 11, 2022 at 17:44

1 Answer 1


You can begin by doing : Reset SMC, Reset NVRAM and booting in Safe mode to clear System caches.

Then you reboot the system.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .