3

The way of deleting keychain access codes is to open the keychain access control and right click on the code and delete which worked before .

But Now It doesn't and when I press delete nothing happens .

How can I force delete any keychain access ? Is there a way by doing this with terminal ?

2
  • 1
    Have you tried deleting from the Safari passwords page? It should have the same effect
    – Ezekiel
    Commented May 23, 2021 at 17:28
  • @EzekielElin It's not related to safari Commented May 24, 2021 at 4:52

2 Answers 2

6

Solved the problem by doing these commands in terminal :

$ git credential-osxkeychain erase return

host=github.com return

protocol=https return

return

return

1
  • 2
    The important thing that isn't obvious here is that the ⏎ symbol represents hitting "enter" and that the trailing two are required. I tried several variations on this and it didn't work until I hit enter each time. Commented Jul 28, 2021 at 18:08
1

I was facing the same problem, I was searching github in the keychain window and then trying to delete them. When doing this nothing happens, but if you just manually scroll and find the github entries from the login tab and then try to delete it a confirm delete popup opens up and the entries gets deleted. Hope it helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .