0

I have a KVM setup that connects several computers to the same Keyboard (Kul ES-87) and Mouse (wireless logitech M525). My monitors are 24 inch, 1920x1200 resolution Dell (2412M and 2415). I connect an Ubuntu machine, one Late 2013 Macbook Pro and a brand new 2019 Macbook Pro 16 inch purchased last week (henceforth, just "MBP 16") for work to this KVM setup (IOGear GCS24U). The MBP16 has AMD Radeon Pro 5300M 4 GB & Intel UHD Graphics 630 1536 MB and has the latest, updated software.

The Ubuntu and the Late 2013 MBP machines connect just fine to my KVM, and have had for years now, but the MBP16 has been extremely flaky with the KVM. The result of the flakiness: it doesn't recognize the VGA monitor (Dell U2412Mb) and after it fails, requires heavy-handed approaches (see below) to fix. I am not sure if these approaches are sustainable.

I connect the two external monitors to the MBP16 in the following way using two separate USB-C ports on the MBP16:

  • MBP16 port 1 -> Benfei USB-C 2 VGA -> KVM (VGA) -> (VGA) Dell 2412Mb // Mostly flaky

  • MBP16 port 3 -> Anker USB-C 2 DisplayPort -> (DisplayPort) Dell 2415 // Always works

(MBP16 port 2 is used for a USB 2.0 hub for ethernet, mic, KVM mouse and keyboard; MBP16 port 4 is used for power.)

I see that the MBP16 connects to the U2415, no problems ever noted. The VGA connection through the Benfei adapter and U2412Mb frequently is flaky (see definition of flaky below). It requires a combination of me switching the KVM port for the MBP16 or reconnecting the VGA on the KVM switch itself that makes the MBP16 recognize the U2412Mb again.

What do I mean by flaky? It works fine so long as it was recognized: wakes up from sleep and re-recognizes the VGA display; after switching to another KVM port, re-recognizes the VGA display. However, if I remove the MBP16 and take it outside of the KVM world (e.g., work on sofa) and get it back, it forgets the VGA. And then it requires all kinds of heavy-handedness to re-recognize the VGA.

  • I am not daisy chaining monitors through a hub (see connection description above).

  • I am running the latest OS on my MBP16 (11.3.1).

  • I have tried, instead of the Benfei USB-C adapter, (1) An apple-store purchased Belkin VGA to USB-C adapter (which did not work at all) (2) an Apple adapter to thunderbolt and then a thunderbolt to USB-C (didn't work at all); (3) a CableCreation multiadapter with Ethernet and VGA to USB-C (worked for 20 minutes). That said, I didn't try using a different KVM port when I tried approaches (1)--(3) above. Also note, a direct connection from Benfei USB-C 2 VGA to the Dell 2412Mb works fine.

  • Last, but not the least, I tried both NVRAM and SMC reset multiple times, didn't do anything.

What is the secret to appeasing the "it just works" Apple gods? Any insight is appreciated.

PS: Post question rant: FWIW, I have noticed it never "it just works" with Apple gear. NFS, CIFS, Guest access, USB connections, USB-based Ethernet, iMessage forwarding, call forwarding to other Apple products, all of which, in my over-a decade experience, has never "it just works" and it always breaks from one release to another.

3
  • My Apple 27" display always works with my 3 macbook pro machines and two need an adaptor to get to usb-c "it just works" especially with Apple gear...
    – Solar Mike
    May 22, 2021 at 9:00
  • I am wondering if the issue may be that the monitor and KVM are both analog signals via VGA. Does the VGA monitor work directly to the MBP? May 22, 2021 at 19:08
  • My VGA monitor did directly connect to the MBP, but that connection is also flaky. May 23, 2021 at 17:41

1 Answer 1

0

The type-C-to-VGA converter cable did not pass the EDID feeding timing correctly to the VGA KVM switch or the VGA KVM switch did not pass or have VGA EDID emulation feeding to the shared monitor.

Please make sure your IO Gear VGA monitor provide Bi-directional EDID emulation and feeding fuction first. If IOgear did not support the EDID emulation, then you may need add an external VGA EDID emulator between the converter cable and the KVM switch.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .