The google fitbit app forwards all iOS imessages to the child's linked fitbit device (Fitbit Ace 3)

I believe this happens simply when app notifcations are enabled.

I feel strongly App notifications should be notifications about that app and NOT randomly forwarding other messages to a separate device.

How do I block this behaviour where Fitbit app is siphoning all Messages into their system?

  • Go into your Fitbit app, select your device, go to notifications, then turn off "Calls" "Text Messages" and/or "Calendar Events" May 20, 2021 at 23:16
  • I believe that the problem you have is off-topic, and I see no reason for you to complain to Apple May 20, 2021 at 23:24
  • Let’s split the two very different questions - even asking two single questions that would be well received (get upvotes) together makes a question here less useful and prone to down votes. Please ask the “how to report” version of this as a new question.
    – bmike
    May 23, 2021 at 13:53

1 Answer 1


The quick solution to this is to turn off the various notifications on the FitBit app. Your app may look slightly different to mine, as I have a Charge 4.

enter image description here

So that your child device doesn't show all notifications, simply turn off "Calls", "Text Messages", and/or "Calendar Events", along with going into "App Notifications" and turning off the ones you do not want.

Note: This answer covers the edited problem not that reporting may be in a separate thread. This is intended to cover the why and practical steps you can take now using the apps / OS that shipped.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .