Something weird I've noticed with Zip files and OSX recently (both on 10.7 and 10.6.*).

Situation: a .zip file with sub-folder and long file names within it. When it's extracted on Windows it extracts all items within their sub-folders properly. When extracted on OSX it does not extract them into sub-folders but puts them all in one folder and then takes the subfolder names and adds it to the file name so you have a super long file name like this:


But it's not in subfolders.

that make sense? Anyone figure out why this happens? I'm not sure what the character length is that triggers this because other files extract fine, just certain ones that exceed a character limit in the name...

  • 2
    Conjecture - I would query the source of the zip files. What happens when you create your own archive file including a suitable directory tree, then unarchive it? Same result?
    – stuffe
    Commented Feb 29, 2012 at 15:15
  • Heya, I'm doing some testing today and seems that this problem occurs even when manually creating a directory tree, etc. So strange!
    – Valien
    Commented Mar 5, 2012 at 15:26

1 Answer 1


This isn't answering your question, but might I suggest you try The Unarchiver - I find it much better than Archive Utility.app. I've used it for years and never seen the problem you've experienced with Apple's utility.

  • Tried in Unarchiver and still same result. Doing some testing to figure out what's going on...
    – Valien
    Commented Mar 5, 2012 at 15:26
  • Very strange. Does this only happen with a small number of files (perhaps from the same source?) or do you see this with all ZIP files?
    – mjturner
    Commented Mar 6, 2012 at 13:12
  • 1
    Semi-found the solution/culprit. It seems when using Izarc in Windows 7 to compress the files it hoses upon extraction in OSX. When I compress in OSX and/or Windows default .zip tool it works fine. Although OSX hidden files tend to show in Windows. So for now I'm good to go since 90% of users are OSX (designers). Strange indeed.
    – Valien
    Commented Mar 13, 2012 at 18:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .