0

I have a local DNS server (bind9) configured to resolve the fqdm of several servers that I have in my local network, until here everything OK.

I put the ip of my local dns server and I can resolve the fqdm of my servers in my local network, but I can't surf the internet. I put the DNS of my internet provider next to the ip of my local DNS server (Bind9) , and I can only surf the internet I cannot resolve the names of any of my local servers.

I try to configure my mac the file resolv.conf (/etc/resolv.conf) adding the line:

-options timeout: 1 rotate attempts: 1

But this has no effect, I still can't resolve the fqdms of my local servers but I can navigate.

I restart the mac and I still cannot resolve the fqdm and also the entry created in resolv.conf has been deleted :(. Any idea how to configure the DNS in macOS so that they rotate and can use the two DNS servers.

1
  • Isn't this a DNS server issue? - you connect from the Mac to your DNS server and it then knows about and forwards requests to internet DNS servers
    – mmmmmm
    May 16 at 19:14
0

The /etc/resolv.conf file is not used for configuring the system resolver, like you would probably be used to on other systems like Linux.

However, the configuration you're trying to make is actually not an ideal one - far from it. You're trying to fix a broken DNS resolver by rotating requests between two different DNS servers. This will add extra time to most name lookups, as well as generate unnecessary errors that for will give you problems with some programs.

The best way to solve this is to change your Bind server to do recursive lookups for your internal clients - either by handling them by itself or by forwarding the recursive queries to your ISPs names server.

In either case you want to limit recursive lookups to your internal clients. This can be done via adding an access-control list to your named.conf configuration file that specifies what you consider internal, like this:

acl internal { 
  localhost;
  localnets;
  192.168.0.0/24;
}

This assumes that your local computers have IP-addresses in the 192.168.0.1-192.168.0.254 range. Adapt as necessary.

If you want the server to handle recursive queries by itself, you'll to add the following to the options part of your configuration:

 options {
   recursion: yes;
   allow-query { internal; };
 };

If you want to forward the queries to your ISPs name servers, do it like this instead:

 options {
   recursion: yes;
   allow-query { internal; };
   forwarders {
      1.2.3.4;
      5.6.7.8;
   };
 };

You'll want to replace 1.2.3.4 and 5.6.7.8 with the actual IPs of your ISPs name servers.

Remember to reload or restart bind after making changes to the configuration file.

2
  • Thanks for your help now everything OK. May 17 at 12:08
  • @ManuelRando Perfect! If this solved your problem, please mark it as accepted!
    – jksoegaard
    May 17 at 14:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .