0

I can't seem to transfer a file from my iPhone to my MacBook (running Big Sur 11.2) recently. I have already checked and that both devices have their Wi-Fi and Bluetooth on. Both devices are set in the "everyone" mode for airdrop. I cannot find the device in the airdrop menu on my phone, and it just shows "No People Found". I have handoff and firewall off on my Mac. However, it works when I send a file from my Mac to my iPhone.

I have searched other questions on this site, but those say that there are no response when they click on it instead of "no people found".

Edit: I've also tried to disable airdrop and enabling it again as well.

I rebooted my mac and it works now. I still wonder why it doesn't work though.

0

If it doesn't happen again, you'll probably never know. That's unfortunately the reality of things.

AirDrop, as much other software today, is based on several very complex subsystems. Bugs happen and it can be difficult or almost impossible to explain them or locate them, unless it is possible to reliably reproduce the problem.

It is very likely that some bug caused some software that AirDrop depends on to be in the wrong state. It could be a driver failure, a bug in the network protocol implementation, or any other bug. When you rebooted the Mac, everything starts over from a valid state - and you won't experience the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .