0

So, I'm trying to install MPlayer X on my new M1 Macbook Pro (http://mplayerx.org/download.html), and I get the now classic "You don't have permissions to open this file" or the like.

Previously I had some issue with another file , I opened the 'Get Info' Window, unlocked permissions and added the Administrator user besides my own user already added, and was able to run the file.

Now, I'm trying to do the same with the MPlayerX app to no avail. I already tried unsuccessfully the sudo upx -d path_to_app and the xattr -d -r com. apple. quarantine. I also tried chmod 777 etc, nothing.

Everytime that I tried to change the permissions for the users staff or everyone, from Read only to Read & Write, I get the 'The operation can’t be completed because you don’t have the necessary permission'

So it looks that even though that my own default account is an admin account, it doesn't have full permissions, it's not a real admin.

What could be a workaround of this? I tried booting, entering in recovery mode and creating a new Admin account, but it was not possible (using rm /var/db/.applesetupdone)

Other ideas?

9
  • 1
    How exactly are you installing MPlayerX? and what is the exact error message
    – mmmmmm
    May 13, 2021 at 13:50
  • I just run the dmg and when it mounts BigSur does not allow to drag it to Applications or to run it from there. May 13, 2021 at 15:43
  • 1
    The download page does say that it is for OSX 10.7 and was updated last in 2016 So I would suggest it is unmaintained and they have not kept up with Apple's chnages - Unless their support has an answer I would look for a more modern app. I used to use this but replaced it 3-4 years by IINA
    – mmmmmm
    May 13, 2021 at 16:24
  • 1
    We would have to see the code for the installer
    – mmmmmm
    May 13, 2021 at 20:25
  • 1
    Missing from this is the location of the file of which you are trying to change the permissions. May 14, 2021 at 0:42

1 Answer 1

1

I actually had the same problem for some of my downloaded apps outside of the appstore .

Try this :

  1. Press command + space and type terminal and press enter to open terminal

  2. Paste this code in terminal and press enter .

sudo chmod -R 755 /path/to/app

Note : to get the path to app simply drag the file you can't open because of permission issues to terminal .

sudo xattr -dr com.apple.quarantine /path/to/app

  1. Next paste this code with the path of the app and press enter .

You can open the file now with no permission problems .

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .