4

We run a small office with approx 10 Macs all running Big Sur. Whenever a new version of macOS comes out we can download the installer once and then reuse it on every machine, but now I'm trying to simplify the update process since, e.g., 11.3.1 which came out recently is 5.7gb and I would like to avoid downloading it 10 times as we have a slow and also metered Internet connection.

I have used softwareupdate -d -a to download the update:

Software Update Tool

Finding available software
Downloading macOS Big Sur 11.3.1
Downloading: 100.00%
Downloaded: macOS Big Sur 11.3.1

I assume I'm looking for a .pkg file (or similar) that can be retrieved before installing, however I cannot find it. I have seen suggestions elsewhere for /Library/Updates but when I use Go To Folder, this only has an index.plist and ProductMetadata.plist in it. (It is also empty if I disable SIP using the csrutil in recovery mode.)

I found this link (https://www.labnol.org/software/upgrade-mac-os-apps/28704/) which talks about enabling a debug menu for the App Store - which will then open up the downloads folder, however that seems to have been removed.

I've had a bit of a sniff around in other places but cannot find anything. I wonder if at this point they're a package contents or similar of an app.

Does anyone know where the update packages are saved and how to retrieve them?

3

3 Answers 3

4

As this is one of the firsts results in search engines, it deserves an answer: Big Sur updates are downloaded in /System/Library/AssetsV2/, more precisely in /System/Library/AssetsV2/com_apple_MobileAsset_MacSoftwareUpdate/

3

macOS Ventura

I was able to get pretty far by first looking for the right process while the installer / updater was downloading:

prompt>  ps -e | grep Update
...
  326 ??         3:41.81 /System/Library/CoreServices/Software Update.app/Contents/Resources/softwareupdated
...

In this case, the update had been downloading a while, so it was the hit with some significant CPU time attached to it.

Then I looked at the list of open file descriptors for that process:

prompt> sudo lsof -p 326   
Password:
COMMAND   PID            USER   FD      TYPE             DEVICE    SIZE/OFF                NODE NAME
softwareu 326 _softwareupdate  cwd       DIR               1,18         640                   2 /
softwareu 326 _softwareupdate  txt       REG               1,18      173792 1152921500312087005 /System/Library/CoreServices/Software Update.app/Contents/Resources/softwareupdated
softwareu 326 _softwareupdate  txt       REG               1,18       51064            32762149 /Library/Preferences/Logging/.plist-cache.KNXNdKum
softwareu 326 _softwareupdate  txt       REG               1,18         110 1152921500312087734 /System/Library/CoreServices/SystemVersion.bundle/English.lproj/SystemVersion.strings
softwareu 326 _softwareupdate  txt       REG               1,18        8597 1152921500312086721 /System/Library/CoreServices/Software Update.app/Contents/Resources/InfoPlist.loctable
softwareu 326 _softwareupdate  txt       REG               1,18       32768            15737817 /private/var/db/softwareupdate/Library/HTTPStorages/softwareupdated/httpstorages.sqlite-shm
softwareu 326 _softwareupdate  txt       REG               1,18      584564 1152921500312337928 /System/Library/PrivateFrameworks/SoftwareUpdateMacController.framework/Versions/A/Resources/SUMacControllerError.loctable
softwareu 326 _softwareupdate  txt       REG               1,18       70162 1152921500312266704 /System/Library/PrivateFrameworks/Install.framework/Frameworks/DistributionKit.framework/Versions/A/Resources/PKDistributionController.loctable
softwareu 326 _softwareupdate  txt       REG               1,18         141            32830714 /private/var/folders/zz/zyxvpxvq6csfxvn_n00000s0000068/T/012-92138_FBE5CBE6-C508-489D-8455-657ADD88F0F3/Payload/System/Library/CoreServices/MajorOSInfo.bundle/Contents/Resources/en.lproj/Localizable.strings
softwareu 326 _softwareupdate  txt       REG               1,18      275381 1152921500312119194 /System/Library/Frameworks/CFNetwork.framework/Versions/A/Resources/Localizable.loctable
softwareu 326 _softwareupdate  txt       REG               1,18       74659 1152921500312121443 /System/Library/Frameworks/CoreFoundation.framework/Versions/A/Resources/Error.loctable
softwareu 326 _softwareupdate  txt       REG               1,18      136152 1152921500312087441 /System/Library/CoreServices/SystemAppearance.bundle/Contents/Resources/SystemAppearance.car
softwareu 326 _softwareupdate  txt       REG               1,18      460384 1152921500312170430 /System/Library/Frameworks/Security.framework/Versions/A/PlugIns/csparser.bundle/Contents/MacOS/csparser
softwareu 326 _softwareupdate  txt       REG               1,18    30407360 1152921500312435095 /usr/share/icu/icudt70l.dat
softwareu 326 _softwareupdate  txt       REG               1,18     1192256 1152921500312119190 /System/Library/Frameworks/CFNetwork.framework/Versions/A/Resources/DafsaData.bin
softwareu 326 _softwareupdate  txt       REG               1,18     2369592 1152921500312111296 /System/Library/Fonts/Helvetica.ttc
softwareu 326 _softwareupdate  txt       REG               1,18     4472724 1152921500312111298 /System/Library/Fonts/HelveticaNeue.ttc
softwareu 326 _softwareupdate  txt       REG               1,18     7851656 1152921500312087402 /System/Library/CoreServices/SystemAppearance.bundle/Contents/Resources/Aqua.car
softwareu 326 _softwareupdate  txt       REG               1,18     2979064 1152921500312087430 /System/Library/CoreServices/SystemAppearance.bundle/Contents/Resources/FauxVibrantLight.car
softwareu 326 _softwareupdate  txt       REG               1,18     5932296 1152921500312087455 /System/Library/CoreServices/SystemAppearance.bundle/Contents/Resources/VibrantLight.car
softwareu 326 _softwareupdate  txt       REG               1,18      130617            32762626 /private/var/db/analyticsd/events.allowlist
softwareu 326 _softwareupdate  txt       REG               1,18      397296 1152921500312080012 /System/Library/CoreServices/ManagedClient.app/Contents/PlugIns/MCXToolsInterface.bundle/Contents/MacOS/MCXToolsInterface
softwareu 326 _softwareupdate  txt       REG               1,18       32768            32762305 /private/var/db/mds/messages/se_SecurityMessages
softwareu 326 _softwareupdate  txt       REG               1,18      297536 1152921500312424156 /usr/lib/libobjc-trampolines.dylib
softwareu 326 _softwareupdate  txt       REG               1,18      257028 1152921500312337763 /System/Library/PrivateFrameworks/SoftwareUpdate.framework/Versions/A/Resources/SUErrorDomain.loctable
softwareu 326 _softwareupdate  txt       REG               1,18       54716 1152921500312337759 /System/Library/PrivateFrameworks/SoftwareUpdate.framework/Versions/A/Resources/Localizable.loctable
softwareu 326 _softwareupdate  txt       REG               1,18      189576 1152921500312266698 /System/Library/PrivateFrameworks/Install.framework/Frameworks/DistributionKit.framework/Versions/A/Resources/Distribution.loctable
softwareu 326 _softwareupdate  txt       REG               1,18      919104 1152921500312111955 /System/Library/Fonts/Times.ttc
softwareu 326 _softwareupdate  txt       REG               1,18     3202372 1152921500312111314 /System/Library/Fonts/LucidaGrande.ttc
softwareu 326 _softwareupdate    0r      CHR                3,2         0t0                 340 /dev/null
softwareu 326 _softwareupdate    1u      CHR                3,2         0t0                 340 /dev/null
softwareu 326 _softwareupdate    2u      CHR                3,2        0t85                 340 /dev/null
softwareu 326 _softwareupdate    3u     unix 0x831adb066ac3e3b9         0t0                     ->0x831adb066ac3f339
softwareu 326 _softwareupdate    4u      REG               1,18 10989076480            32830863 /private/var/folders/zz/zyxvpxvq6csfxvn_n00000s0000068/C/com.apple.SoftwareUpdate/swcdn.apple.com/content/downloads/25/16/012-92138-A_KGGGN26YQB/d0kr042ixfvkboeft8qt2i3aclr5bx1e6p/InstallAssistant.pkg.partial

The hit in this case is the one with the very large size at bottom in private/var/folders/... (The download had been going a while.) So, that is how to find them as they are being downloaded.

In my case, once the download finished, this file disappeared. This is to be expected. .partial files are auto renamed when the download finishes. What it is unpacked to and where that ends up probably very much depends on what it is. With any luck it will be in the same place.

In my case, since I was doing an OS update, a very obvious /Applications/Install macOS Ventura.app appeared when the OS installer launched. If you are doing something else, then while it is installing, my bet is lsof will spot the file for you, though I'm not sure which process it will be that is doing the installing. The ps or top commands might be your friend spotting it. Work fast! Otherwise, the usual convention is that the non-partial file will be in the same place as the partial file with ".partial" removed.

Assuming like me, what you really want is a bootable OS install disk image, you can follow the Apple directions for making a bootable installer image as long as the update app in Applications is still there: https://support.apple.com/en-us/HT201372

This mostly boils down to:

  1. Without closing or disturbing the OS installer app (leave it running)...
  2. Find a thumb drive that is big enough
  3. Using Disk Utility, erase the thumb drive and reformat as MacOS Extended
  4. Make the installer on the new thumb drive. In my case, the thumb drive is mounted at /Volumes/Install:

Making the installer:

 prompt> sudo /Applications/Install\ macOS\ Ventura.app/Contents/Resources/createinstallmedia --volume /Volumes/Install
 Password:
 Ready to start.
 To continue we need to erase the volume at /Volumes/Install.
 If you wish to continue type (Y) then press return: Y
 Erasing disk: 0%... 10%... 20%... 30%... 100%
 Making disk bootable...
 Copying to disk: 0%... 10%... 20%... 30%... 40%... 50%... 60%... 70%... 80%... 90%... 100%
 Install media now available at "/Volumes/Install macOS Ventura"

With any luck you should be able to boot off that. You may need to use csrutil to disable system integrity protection before the Mac will find it at boot time.

2

Welcome to the site.

First of all, I can very much empathize with this situation. For years we lived behind a slow satellite connection which had a quota of 20GB per month.

Unfortunately, the bad news is that softwareupdate is no longer supported by Apple for system updates in Big Sur. I am not even sure that it is possible to do what you are trying to do. Apple used to post ‘combo updaters’ to their website, but they have also ceased to do that.

One of Apple’s perpetual blindspots is that not everyone has access to fast and unlimited Internet access.

Your best bet is to set up “Content Caching” on your local network:

What is content caching on Mac? - Apple Support

Set up content cache clients, peers, or parents on Mac - Apple Support

(Note: I have had some trouble loading some pages on Apple’s support page in Safari. It works sometimes and other times says that the page does not exist. If that happens, try another browser. Yeah, I know, absurd.)

Content Caching is not as easy or as precise as combo updaters were (for one thing, I don’t know of any way to force a Mac to only use a content cache… it’s just supposed to happen “automagically” and we know how that goes.

I wish I had a better answer for you. Unfortunately, Apple has chosen to deprecate softwareupdate and discontinue Combo Updaters, which makes this situation extremely difficult to manage, especially with bandwidth restrictions.

5
  • HI TJ. Thanks. I experimented with the 'Server' version of what was OSX at the time, thinking that was surely the way to manage a small network of Macs... but obviously that's long gone. As for Big Sur not supporting softwareupdate - that is indeed another mystery... I ran the command and it definitely looked like it was doing... something. I really hope I haven't downloaded 5.7gb that is completely unusable!
    – matt
    May 13, 2021 at 11:47
  • I can't say for sure, but I will tell you that, before I knew this, I ran the softwareupdate program to update to 11.1, it went through the whole process and even rebooted my Mac … but didn't apply the update… and when I tried to run it again, it re-downloaded the entire thing. I am not sure where to look for the download.
    – TJ Luoma
    May 13, 2021 at 15:43
  • Oh, and the caching server is now built right into macOS, so you don't need the "Server" portion at all.
    – TJ Luoma
    May 13, 2021 at 15:45
  • Oh, and I also meant to recommend looking at github.com/munki/macadmin-scripts/blob/main/… but I don't know if it does updates. I think it just does full installers. Munki and Jamf resources may be a good place to learn how this sort of small network management.
    – TJ Luoma
    May 13, 2021 at 15:48
  • Thanks. May well explain why /Library/Updates is empty even with SIP disabled if softwareupdate hasn't actually done anything! How frustrating.
    – matt
    May 14, 2021 at 10:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .