When I want to open an app which I've downloaded outside of app store a pop up with the message of You dont have permission to open this app shows up.

enter image description here

My laptop is macbook pro 2020 m1 big sur version 11.1

enter image description here

I've checked of my user is the administrator or not and I found that I'm the only admin account on this laptop :

enter image description here

I've also tried to open app with rosetta but didn't work either and also tried to make all users able to read and write in the permissions of the app info .

enter image description here

I hope anyone could help me open such apps . Thanks in advance .

  • Have you tried a "right-click" with the mouse on the application icon, then in the contextual menu, you choose "Open", it should work after confirming your choice to open.
    – user415185
    Commented May 11, 2021 at 5:53
  • 1
    @Jean_JD It didn't work Commented May 11, 2021 at 13:40

1 Answer 1


The cause of the issue may be the quarantine extended attribute and the Unix permissions. You can solve the issue by changing the permissions and deleting the extended attribute, running two commands in Terminal.

The first command changes the permissions to read, write and execute for the User and read and execute for Group and Other.

The second command strips the quarantine attribute.

sudo chmod -R 755 /path/to/app.
sudo xattr -dr com.apple.quarantine /path/to/app.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .