2

I have a MacBook Pro (Retina, 15-inch, Mid 2015) running Mac OS Mojave. When I boot it up, it shows a grey screen with a question mark on a folder.

I have figured out that the issue is with the internal SSD as I can boot from a USB installer with Mojave just fine. I can see the internal disk with diskutil and also see /Volumes/Macintosh\ HD/ from the terminal. I was able to recover the few files this way that I hadn't backed up earlier. However this was too slow as even an ls command on the Macintosh HD Volume takes a couple of minutes to execute and the system.log in /var/log shows loads of error messages of this type: Kernel[0]: disk1: I/O error. But, I managed to get the files I needed.

Now I want to wipe the SSD or atleast erase the data from the /Volumes/Macintosh\ HD/, but I am not able to do that. I tried Disk Utility but it just hangs every time I open it and running diskutil from the terminal on always ends up with some error. I have tried verifyVolume, repairVolume, eraseVolume, deleteVolume, deleteContainer and eraseDisk with diskutil but they all end with an error which looks something like this: Error: -69877: Couldn't open device or similar to this.

I found this answer here to delete the APFS partition using a bootable USB with Linux Mint. This ended with an error message too saying Input/output error.

Is there any way I can wipe the SSD clean?

The disk and the volume are not encrypted and I have also tried resetting NVRAM, PRAM and SMC but none of that helped. Booting up into Recovery Mode doesn't help either. It shows a spinning globe but there is no progress bar, and nothing happens.

1 Answer 1

0

You can try :

diskutil zerodisk force diskX

Where diskX is to be replaced by the internal SSD indentifier.

But given the previous errors, I doubt the effectiveness. The best solution is to remove this SSD by following this link: https://www.ifixit.com/Guide/MacBook+Pro+15-Inch+Retina+Display+Mid+2015+SSD+Replacement/48251

5
  • Thanks. I don't think I passed the force option when I tried earlier. I suspect that eraseVolume and eraseDisk would be using zerodisk in the background to erase the disk but I will give it a go anyway.
    – Nivranshu
    May 11, 2021 at 11:46
  • No eraseVolume or erasedisk remain at the logical structures level while zerodisk attempts to erase all information from the disk, including structures. But I have a doubt seen the I / O errors. It will certainly be necessary to change the SSD. You have the option of replacing the original Apple SSDs with NVME M2 models with adapter, much cheaper and just as efficient.
    – user415185
    May 11, 2021 at 12:00
  • 1
    No luck here, but received a different error this time: Error -69759: Securely erasing data to prevent recovery failed. Underlying error: 5 I think I have seen error message 5 before when I tried to format the disk from Linux Mint.
    – Nivranshu
    May 11, 2021 at 18:36
  • Have try open the Mac, extract the SSD, clean contacts and remount it? This link can help you : ifixit.com/Guide/…
    – user415185
    May 11, 2021 at 18:43
  • I don't have any tools on me at the moment to do this, but it looks like that is the only alternative. Thanks.
    – Nivranshu
    May 11, 2021 at 19:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .