5

Basically the "updates page" loads in a non rich html format, and if theres an update it's missing the tabs on the update page as well. I can't figure out if this is just because apple may have stopped supporting El Capitan or if I have something else going on. Any help would be appreciated. I've trashed the caches in library and the user profile. But this page is the only one that still loads like this (see pic below) on my app store.

updatespage in app store

2
6

It's been that way for quite a while - I'd assume it's simply no longer supported for El Cap, but I have no citation for that.

You have to bear in mind that there will no longer be any updates for any apps on El Capitan [nor indeed for the OS itself] - many apps are now minimum spec Mojave, some a little older some newer, but no-one is going to be testing against El Capitan any more. It was superseded 5 years ago & generally support is to 3 years.

As noted, this applies up to High Sierra - the only difference on High Sierra is it lists all the updates you can't have, also in plain text ;)

enter image description here

11
  • I called apple and spoke to 3 advisors, including head tech and they said it's not supposed to show up like this. Yet they were unable to solve the issue. When I tried updating to High Sierra-same issue. I tried Mojave, then my Notes app started Facetime. No matter how I installed it, so I had to revert back to El Capitan. I tried High Sierra, fresh install and Mojave. I can't seem to get rid of that bug either. However the issue doesn't seem to be in guest user; so somehow my notes is pulling some preference. I just don't know how to migrate my data back – Mark May 6 at 16:22
  • You cannot 'migrate downhill' you must have a complete clone to revert to. – Tetsujin May 6 at 16:35
  • I wiped the drive clean and then did a time machine restore to go back. – Mark May 6 at 16:38
  • no other issues for el capitan other than the update store view. All works:) When moving forward to Mojave, I get the Notes launching FaceTime issue. ( – Mark May 6 at 16:39
  • You've got to be really careful with Time Machine. if it backs up even once on the newer OS you can lose the ability to go back. The wise move is to disconnect it if you're testing newer OSes. The smart money is also on distinct clones at each step - but that depends on how many spare hard drives you have. See apple.stackexchange.com/q/271104/85275 for a sad & sorry tale ;) – Tetsujin May 6 at 16:48
5

This is a known problem. On all osx versions prior to Mojave Appstore is displayed in "text" mode. CSS issue not resolved to date. This does not, it seems, interfere with proper operation.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .