2

Question

My Safari preferences pane looks like this:

enter image description here

How do I fix this? Can I change these settings by editing or creating a plist file?

I'm on macOS Big Sur (version 11.3) on a 2019 Macbook Pro 16-inch. Safari version is Version 14.1 (16611.1.21.161.3).


Here are some things I've tried

I have looked in every potentially related plist file I could find and didn't see anything that looked like a culprit. I moved the main Safari plist file to Desktop and restarted my computer to see if it would work--it didn't.

Also, I tried this:

I went to System Preferences > Security & Privacy > Privacy, scrolled down to Full Disk Access, gave Terminal full disk access, then did:

defaults write com.apple.Safari AutoFillMiscellaneousForms -bool true
defaults write com.apple.Safari AutoFillCreditCardData -bool true
defaults write com.apple.Safari AutoFillPasswords -bool true
defaults write com.apple.Safari AutoFillFromAddressBook -bool true

That still didn't work. The com.apple.Safari preferences reflect the changes, but a restarted Safari does not. The options are still unchecked and grayed out, and no autofilling happens on websites I visit.

10
  • What happens if you click one of the "Edit..." buttons? If you add something there can you then click a checkbox? May 5, 2021 at 22:55
  • @SteveChambers Thanks. I tried that. They take me to other apps (like Contacts, or the Passwords list). Deleting or adding a Contact, for instance, does nothing to these checkboxes. May 6, 2021 at 0:09
  • Is this a work computer managed by an IT org? MDM profiles allow disabling of autofill as a security policy
    – vykor
    May 6, 2021 at 1:11
  • @vykor It is a computer managed by IT for work. It has an MDM profile. An IT rep said that there are no rules against disabling autofill and suggested looking through the preferences to make sure it was checked "on". Do you know how I could verify if my MDM profile disables autofill? May 6, 2021 at 1:55
  • If you create e new User on this Mac, have the same problem?
    – user415185
    May 6, 2021 at 4:44

1 Answer 1

0

+1

I have the same problem but with a twist. For me, only password is disabled. I also have a computer managed by IT. I tried to follow @user415185 advice and create a new user. But that is disabled.

Same, same, but different

1
  • This sounds like an MDM setting that IT needs to change.
    – Barmar
    Aug 30, 2023 at 17:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .