1

It's formatted HPS+. Mounted fine yesterday (and for a long time before that). Now, the light on the drive blinks on-and-off and it sometimes briefly shows up in the output to diskutil list as /dev/disk3. I've tried diskutil eject disk3 and similar variants.

The drive automatically mounts on linux without issue.

I do not see fsck running (I checked with ps auxw and top from a terminal). I did not find any interesting log messages via the Console program.

We had trouble about a year ago. Apple support recommended upgrading the OS and I think that worked. We also bought a second cable for the external drive, but ended up not needing it. I just tried the second cable and it didn't make a difference. There was an upgrade OS available and we tried that after talking to Apple support this time, but it didn't make a difference. The drive mounts fine on a ~2016 Mac Air.

12
  • If your Mac isn't a M1 model, have you try do a SMC Reset?
    – user415185
    May 5, 2021 at 5:57
  • Does the port on the Mac work for other devices?
    – benwiggy
    May 5, 2021 at 10:18
  • @Jean_JD Yes, Apple support had us do an SMC reset.
    – jrennie
    May 5, 2021 at 13:30
  • @benwiggy We have it connected via a usb hub that also connects a mouse and keyboard. We tried connecting the hub to a different usb-c port on the mac (swapping with an external monitor hookup). Same behavior as before. Thanks for the ideas!
    – jrennie
    May 5, 2021 at 13:30
  • If you boot the Mac in Safe Mode, have you the same problem?
    – user415185
    May 5, 2021 at 13:36

1 Answer 1

1

A few days after posting this, we got a usb-c cable for the drive and had no trouble using the drive with a direct connection. A few days later, the hub that we were using to connect the drive completely died. So, the hub was clearly the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .