0

I recently got an iMac they did erase the internal drive for me but for making sure every step is correct I tried to erase the internal drive myself from recovery mode before reinstalling the macOS. but this time it stocked on erasing exactly on the "Deleting volume" step. I waited for more than 15 hours but the progress bar was 0%

enter image description here

then I gave up and restart the iMac, this time I tried to reinstall from recovery mode, but this time in choosing the installation disk, I saw it's grayed and says "this drive is locked".

the only solution I found for the locked drive was to erase it again. but my erasing has problem as I said

3
  • 3
    You need to enable "Show All Disks" in Disk Utility, you didn't erase the correct one. May 4, 2021 at 18:21
  • 1
    Can you get into Internet Recovery? If so, once you are in Disk Utility, then press Cmd/2 which will show the actual hard drive rather than just the volumes & you can then Erase the drive instead. You can't do this from local Recovery.
    – Tetsujin
    May 4, 2021 at 18:22
  • @At0mic I dont know how to thank you man!!! I'm in installation process right now thanks to you
    – mos2g
    May 4, 2021 at 18:58

1 Answer 1

1

thanks to my friend @At0mic who commented on my question. by choosing "Show All devices" I was able to erase the parent disk and that went smoothly and now I'm in the installation process :)))

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .