1

When I try copying a file from the phone to a computer I get an error "Error Copying File or Folder" - "A device attached to the system is not functioning"

This is running iOS 14.4.2 and the PC is Windows 10. I've tried two genuine Apple cables - a USB-C to lightning one and a USB-A to lightning and get the same result.

Rebooting the phone fixes this and I can copy one video and then I start getting the error again.

I'm thankful I at least have a workaround with rebooting, but any thoughts on how to solve so it can work as expected.

Here's a screenshot of the error:

enter image description here

If I try again after getting this error I get one saying "The device is unreachable" - see screenshot below:

enter image description here

1
  • 1
    If the iPhone is fully updated then the best bet is to back it up to your PC using iTunes, wipe the iPhone and then restore from the backup. This procedure fixes a bunch of odd iPhone issues and this is one of them. May 2, 2021 at 15:47

2 Answers 2

1

To solve this, go to Settings -> Photos and scroll down and change the "Transfer to Mac or PC" setting from "Automatic" to "Keep Originals"

I believe the issue is the iPhone trying to do a real time conversion. The benefit of it this too is smaller file size and faster transfer.

0

You can install MacroPlant iExplorer onto Windows, and a pre-requisite for installing that, is installing iTunes onto Windows.

MacroPlant iExplorer will show the files and has an option to copy the files.

I have done that on Windows 7, though no doubt it'd apply to Windows 10 too. I think somebody once mentioned iMazing do some software too that does a similar thing.

So while that's an issue it seems between ios and Windows. A related oddity is even between apple ios and apple mac osx, apparently an iphone 12 (and perhaps other iphones too) , when connected to a computer running an early Mac OS version like v10, high sierra, doesn't show up anywhere but in itunes (or software which uses itunes like macroplant iexplorer or i suppose something by imazing).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .