3

Edit: The problem somehow resolved itself today. I'm not sure how, but I suspect it is because I restarted the computer. I don't believe granting Finder.app full disk access was needed, since I undid that yesterday.

Original post: I can't change icons on APFS-formatted external drive volumes. I've tried many things as detailed below, but nothing is working for me as demonstrated by the screen recording below (click for higher quality): enter image description here In the screen recording you see that I'm able to change the icon on "old Mac Pro" which is an external volume formatted as Mac OS Extended Journal (using the usual procedure: pasting an image into the upper left of the Get Info). However, the same procedure does not work on the APFS formatted volume, regardless of whether I copy/paste or drag either .png or .icns formatted images.

I've tried this on both a 2015 MacBook Pro and a 2020 M1 MacAir, both running Mac OS 11.3.

===========================

Details of what I've tried: This site says .icns files are required sometimes (since Catalina). This site describes making .icns files using Preview (I found this works for icons when images are 512x512). This video shows making .icns files using a automator quick action found here. User BOrax on this site suggests a need to grant Finder.app full disk access, which I tried using System>Security>Privacy>Full Disk Access> hit + then navigating to /System/Library/CoreServices/Finder.app -- again, nothing helps.

5
  • Does the external disk have macOS installed on it and if yes, what version? Also if yes, what's the output for ls -al /Volumes/APFS | grep ".VolumeIcon.icns"
    – Redarm
    Commented May 2, 2021 at 15:00
  • @Redarm Yes, 11.0.1 is the version and the output of your Terminal command is: -rw-r--r--@ 1 tony staff 553956 May 2 12:27 .VolumeIcon.icns
    – Tony M
    Commented May 2, 2021 at 15:38
  • 2
    I had a similar issue, where I've changed to an actual ".VolumeIcon.icns" file on the system volume of a Catalina installation - the icon never showed on the Desktop after that, unless booted from. macOS puts the icon onto the data volume ("APFS - Data") and the system volume should only have a relative link to it, i.e. the output should show a link .VolumeIcon.icns -> System/Volumes/Data/.VolumeIcon.icns, not the icon image itself. You should be able to achieve this from either you HFS+ volume, or from the Recovery volume, i.e. from anywhere that lets you write to the system volume.
    – Redarm
    Commented May 2, 2021 at 16:27
  • @Redarm It sounds like you have the answer. I suggest you post an answer so that I can try it and mark it as the answer. I understand booting from another volume, but it would be helpful if you provide detail after that; ie, the steps to be carried out where you say, "You should be able to achieve this from either you HFS+ volume, or from the Recovery volume"
    – Tony M
    Commented May 2, 2021 at 16:39
  • Try pasting the icon directly onto the Data volume first of all (in /System/Volumes/APFS). My issue was with Catalina, which was easy to write to, whilst booted into Sierra. Yours is Big Sur, which is not as straight forward and may take some time for me to post steps. See as example: eclecticlight.co/2020/06/25/… Does installing Big Sur over it not replace the icon with a link?
    – Redarm
    Commented May 2, 2021 at 21:45

2 Answers 2

2

In a similar issue I had an actual ".VolumeIcon.icns" file on the system volume of a Catalina installation, instead of only on the data volume, just linked to from the system volume. Only the generic icon showed on the Desktop, no matter what.

Removing this icon file and replacing it with a link to the data volume (as intended) solved the issue for me and I could subsequently paste an icon that did show on the Desktop again.

Also, when pasting a new icon, use the Data volume, not the icon on the Desktop. If you cannot find it in Finder, use Disk Utility, select "APFS - Data" in the sidebar, right-click and choose "Show in Finder". You could try this, before carrying on removing the icon file on the system volume.

Since you are running Big Sur on the external drive, which seems to have an actual icon file in the system volume's root directory, I've tried an exercise and removed the link there on a Big Sur volume and again replaced it with the same link: .VolumeIcon.icns -> System/Volumes/Data/.VolumeIcon.icns

Setting the external drive (in your case named "APFS") as startup disk in System Preferences, I rebooted into its Recovery, holding cmdR at reboot.

There - launching Terminal from the "Utilities" menu - I disabled authenticated root with...

csrutil authenticated-root disable

(Note: csrutil disable was used earlier, but I don't think this should make a difference)

Without restart I checked the volumes and their mount path with... mount ...which shows the system and data volumes of the drive in question (named "APFS" and "APFS - Data" respectively). The system volume clearly shows "read-only":
/dev/disk6s5 on /Volumes/APFS (apfs, sealed, local, read-only, journaled)

So I went ahead and mounted it writeable:

mount -uw /Volumes/APFS

...and checked that "read-only" had gone with another mount command, which showed: /dev/disk6s5 on /Volumes/APFS (apfs, sealed, local, journaled)

Going ahead, I removed the link (which would be a file in your case):

rm /Volumes/APFS/.VolumeIcon.icns

...changed to the root directory of the drive's system volume...

cd /Volumes/APFS

...and created the link again:

ln -s System/Volumes/Data/.VolumeIcon.icns .VolumeIcon.icns

Checking again with... ls -al ...showed the correct link:

lrwxr-xr-x   1 root  wheel    36  3 May 14:10 .VolumeIcon.icns -> System/Volumes/Data/.VolumeIcon.icns

Now I deviated from the instructions on this site and did not bless a new snapshot

bless --folder /Volumes/APFS/System/Library/CoreServices --bootefi --create-snapshot

...but just rebooted twice into the APFS volume, which I was allowed to do (maybe deleting the link and just recreating it was not considered change enough).

PS. The question is though, if this is worth doing for the sake of an icon on the Desktop.

3
  • I'm marking this as the answer because I have learned so much through it. However, I did not carry out the steps here. Somehow the icons began showing up today, and my best guess is that it was because I restarted in the meantime. See original post for more details.
    – Tony M
    Commented May 3, 2021 at 17:51
  • Thanks, so nothing like my issue then, which lasted for months and through various reboots and upgrades. It sounds more like a cache issue. Did you try unmounting and remounting the volume before rebooting?
    – Redarm
    Commented May 3, 2021 at 18:57
  • I don't believe unmounting and remounting is the solution to the problem I was having because I tried that and it didn't help. I tried it because I'm aware of another quirk: that you sometimes can't rename an APSF volume and yet when you unmount and mount it allows you to rename.
    – Tony M
    Commented May 3, 2021 at 19:49
0

I was having the same problem but found that simply opening Disk Utility, selecting the drive in the left panel and then dragging an icon file (icns, jpeg, etc of 515x512) over the default icon will change the icon for the drive. Hope this helps someone.

3
  • The OP clearly states that this does not work in the question.
    – Thinkr
    Commented Apr 14, 2023 at 15:19
  • @Thinkr I don't see any reference to using Disk Utility in the question. For me it looks like the question is talking about using Finder's Get Info option and pasting over the image in there. I am saying that I tried to do that and it failed but it did work when I used Disk Utility and dragged the icon file over the icon in Disk Utility NOT Finder's get info. Perhaps I'm misunderstanding you. lmk. Thanks Commented Apr 17, 2023 at 15:59
  • Seems that I have misunderstood the gif in the question then
    – Thinkr
    Commented Apr 17, 2023 at 16:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .