2

Final update: problem fixed, it was seemingly a loose LCD flex connection. I took the screen off, reseated the flex and applied a generous serving of Kapton tape; one piece across the FPC connector and one piece pulling the flex cable towards the connector. Hope this helps others with the same issue

Kaptop tape

1280x720 is the only option available "Default for display" is 720p, and 1280 x 720 is the only "Scaled" resolution available

Many users have asked this question, but nobody seems to know the answer. Mine just did it last week, and I took it to Apple today; diagnostics showed that everything was working correctly.

The following solutions are confirmed to not work:

  • Resetting SMC/PRAM (multiple times)
  • Booting into safe mode
  • Clean install of Mac OS X/macOS
  • Booting into Windows (Boot Camp, presumably) on the Mac
  • Replacing the LCD data cable

Other things I've tried:

  • An external 1440p monitor connected to the iMac will work at its native resolution (ruling out GPU issue)

iMac 27" 2009 works at 1440p Late 2009 iMac 27" in Target Display Mode works as an external display via Mini DisplayPort cable

  • Using the iMac as a monitor for another Mac via Target Display Mode (TDM) works at the iMac's native 1440p resolution (ruling out internal LCD/data cable connection issue).
    • TDM behaves differently now. Brightness of the iMac can't be adjusted, and while its speakers are exposed as a sound output option in the host Mac, no sound from the host Mac plays through the iMac speakers. Also, it takes two presses of Command ⌘ + F2 to exit TDM.

27" iMac running at 1440p via TDM Mid-2012 Retina MacBook Pro 15" connected to the Late 2012 iMac 27" in TDM

  • Booting off of a live Ubuntu USB drive boots up with no display unless the nomodeset boot argument is used, which then allows Ubuntu to display at 720p

  • Exporting the EDID using SwitchResX shows that the EDID is not corrupt, and appears identical when exporting from the iMac itself and from another Mac when it is connected in TDM (Pastebin)

  • Setting the resolution to 2560x1440 using SwitchResX will allow the UI to appear as 1440p should, but the rendered resolution is still 720p (in other words, it looks like 720p at 0.5x scaling)

One user has fixed it after a PSU and SSD install procedure caused snowy display, by reconnecting the LCD data cable. But this isn't applicable to those who encountered the issue on the iMac from when it was relatively new, i.e. never pulled apart before (first couple of Apple Discussions links) or if the LCD data cable was replaced entirely (Ask Different link)

Does anyone have any further insight into this problem?

Update: 800x600 has mysteriously appeared as the only other available resolution. Update 2: 800x600 has mysteriously disappeared, leaving 1280x720 as the only available resolution.

how does this even happen

7
0

@aklh, thanks for gathering these pieces of information. After I reassembled the screen, I had the same situation: first snowy display, then boots up with a low resolution. After I tried all solutions mentioned in this post and failed, here is my fix. Clean the connector on the LCD data cable and the slot on the board completely before connecting them. When you connected the cable, squeeze the connector a little bit to the board to make them fully touched. A loose connection probably causes the snowy display, and the macOS is forced to go back to the basic display mode. This works for me. I hope it helps.

1
  • I opened up the iMac, reconnected the LCD flex and put a fair bit of Kapton tape over the connector, and it works! It's a shame the 100 point bounty ran out before you answered
    – aklh
    Oct 15 at 3:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .