I screwed up while using Monolingual and removed the "AppleKeyboardLayouts.bundle". Before I realized what happened, I logged out and now I can't type a password to log back in.

I have tried to copy the bundle to the right location, using Sharing but I get "not enough write permissions." I tried using scp in Terminal but I get "no such file" on all the bundle contents.

What is the best way to copy a bundle to one of the System folders /Systems/Library/Keyboard Layouts/ from one Mac to another over the network?

I know that I can probably restore from a boot disk but I'd prefer to just do it this way if possible.

Help! Thanks.


To copy your "AppleKeyboardLayouts.bundle" to a system folder you need "root permission!" use cp (copy) or mv (move) with sudo (super user) to copy files.

If you let's say try to copy folders or files that have a recursive structure/architecture you need to add the -r flag, like so: cp -r ~/Desktop/myFolderA ..

sudo cp ~/yourPath/AppleKeyboardLayouts.bundle /Systems/Library/Keyboard\ Layouts/

It is always a good idea imho, to have a second partition ready on the same HDD in order to copy files back and forth, if needed, or at least to have a second user account with sufficient permissions.

  • 1
    Thanks! So I was trying sudo cp -r /System/Library/"Keyboard Layouts"/AppleKeyboardLayouts.bundle /Volumes/Mini/System/Library/"Keyboard Layouts"/ and I was getting a bunch of "No such file or directory"s. Feb 28 '12 at 7:08
  • i see. are you certain that your 'dir' is valid?! i can't see a typo so far. try to drag the .bundle you want to copy into terminal.app after "sudo -r" and then type in your location.
    – v2r
    Feb 28 '12 at 7:25
  • Thanks. Should /Volumes/<Name of Mac>/ work? Because the very first error i get is No such directory on that location. Feb 28 '12 at 7:29
  • you are welcome!! why not drag and drop both locations into terminal (if possible over your network from mac01), to make sure, there are no typos and the path is correct.
    – v2r
    Feb 28 '12 at 7:36
  • Still not working. I can copy the file to another location on the volume, but not to /System/Library. Even with sudo. Feb 28 '12 at 14:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .