I've configured a host only adapter in Parallels Desktop. If I type ifconfig in the terminal that network adapter is listed in the output like:

    ether fa:ff:c2:xx:xx:xx 
    inet netmask 0xffffffe0 broadcast
    inet6 fe80::c67:xxxx:xxxx:xxxx%bridge101 prefixlen 64 secured scopeid 0x14 
        id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0
        maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200
        root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0
        ipfilter disabled flags 0x0
    member: en11 flags=3<LEARNING,DISCOVER>
            ifmaxaddr 0 port 19 priority 0 path cost 0
    member: en12 flags=3<LEARNING,DISCOVER>
            ifmaxaddr 0 port 21 priority 0 path cost 0
    member: en13 flags=3<LEARNING,DISCOVER>
            ifmaxaddr 0 port 22 priority 0 path cost 0
    member: en14 flags=3<LEARNING,DISCOVER>
            ifmaxaddr 0 port 23 priority 0 path cost 0
    member: en16 flags=3<LEARNING,DISCOVER>
            ifmaxaddr 0 port 25 priority 0 path cost 0
    nd6 options=201<PERFORMNUD,DAD>
    media: autoselect
    status: active

Before I've upgraded to Big Sur, I was able to see those adapters also in the (visual) network settings of OSX. Now it is not listed there anymore. Is there a way to show them also in Big Sur?

1 Answer 1


Finally, I found the answer in the Parallels knowledge base (https://kb.parallels.com/125286):

After upgrading macOS to Big Sur, Connect Mac to this network and Show in System Preferences options disappeared from Parallels Desktop preferences > Network..

Show in System Preferences option can not be selected so Host-Only network cannot be found from macOS System Preferences > Network.

These features are now hidden due to macOS Big Sur restrictions (KEXT-less network mode): In macOS Big Sur Apple restricted usage of kernel extensions and Parallels Desktop does not load them by default, instead it uses macOS own built-in mechanism.

Downgrade to Parallels Desktop 16.0.1 or earlier - make sure the version is compatible with macOS Big Sur.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .