1

When typing something into the search / address bar in Safari or Firefox, the predictions and autocorrect are disabled. This means I don't get suggestions to complete the current word I'm typing either.

Is there a way to enable this functionality? It does seem to work in a lot of places e.g. iMessage, but also realised it doesn't work in the app store search bar.

I've just moved over from Android, so apologies if this has an obvious answer.

Phone is running iOS 14.4.2

1
  • Please include the iOS version as Apple often makes changes when introducing a new OS.
    – Mockman
    Apr 30 at 11:12
1

The QuickType predictions don’t show when the text field has autocomplete disabled.

This is most often seen in inputs where completions appear as part of the text entry in the app. For example, regular QuickType predictions don’t appear in the Safari address bar because Safari shows autocomplete suggestions from your selected search engine. This is the same for App Store search, Spotlight, and others.

0

Though grg's answer says why this happens, it does not fix the problem.

My workaround has been switching to use SwiftKey instead of the default keyboard, this enables predictions seemingly everywhere.

-2

How to use Auto-Correction and predictive text…

In Settings > General > Keyboard you should see switches to enable Auto-Correction and Predictive.

For quick, alternate access, touch and hold the 'emoji' or 'globe' icon when the keyboard is visible. If the keyboard language supports it, you should see a switch for 'predictive'.

If the issue is specific to search suggestions, then these can be enabled in the Search section of Settings > Safari. If they're enabled but not working, try toggling them off and on again. I don't use Firefox on iOS but try Menu > Settings > Search > Show Search Suggestions

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .