1

I just upgraded to Catalina and am using an external drive as a system drive and need to unmount my internal drive, but I can't. I try sudo diskutil umount /Volumes/Macintosh\ HD/ and it asks for my password, tries, then tells me:

Volume Macintosh HD on disk0s2 failed to unmount: dissented by PID 2793
(/System/Library/CoreServices/Dock.app/Contents/XPCServices/com.apple.dock.
extra.xpc/Contents/MacOS/com.apple.dock.extra)
Dissenter parent PPID 1 (/sbin/launchd)

When I use ps aux to find out about PID 2793, here's the appropriate information:

hal               2793   0.0  0.1  5253644  34068   ??  Ss    1:06AM   0:00.14
/System/Library/CoreServices/Dock.app/Contents/XPCServices/com.apple.dock.extra.xpc
/Contents/MacOS/com.apple.dock.extra

The only app (and I checked with lsof) that is using anything on that drive is the dock - and it's using the iTunes icon. I found that out with lsof, here's the related output line:

com.apple 2793  hal  txt       REG                1,2      23760             2640732
/Volumes/Macintosh HD/Applications/iTunes.app/Contents/PlugIns/iTunesDockTile.docktileplugin
/Contents/MacOS/iTunesDockTile

That confirms that the only app using anything on that internal drive is the Dock and that the only file being used is the iTunesDockTile. When I first saw this, I removed Apple Music from the Dock, but it still wants that tile and, rather than getting it from the external drive, that is the system drive, it's using the one on the old internal drive.

I tried killall dock; sudo diskutil umount /Volumes/Macintosh\ HD and get the same message as above. (I hoped that it would unmount the drive while Dock was restarting and before it got a file lock.) I've considered just deleting that file, but I don't know what consequences that would create.

I need to unmount that drive so I can reformat it.

Extra (probably unnecessary) details:

This is part of an upgrade from Mojave to Catalina. I tried to start the update and it wouldn't, since my system drive was not in APFS. I had an extra drive, so I hooked it up via USB and formatted it in APFS, then used SuperDuper to copy my internal drive to the external. I upgraded the external to Catalina. My next step was going to be to reformat the internal in AFPS, then use SuperDuper again and copy everything on the external drive (Which is now a new Catalina update) to the internal drive. It appears EVERYTHING else is using the external for all system resources and the ONLY tile the Dock is not getting from the internal drive is this one iTunes tile.

So what is the best and safest way to deal with this to unmount the internal drive? I've considered using a forced unmount, but that doesn't always work and can cause problems. I don't want to just delete the tile file until I know what it'll do or if there are unexpected consequences.

5
  • Would you not just boot to macOS Recovery over the internet or external drive or from a USB flash drive macOS installer, then use a Terminal window to issue the command to reformat the drive? Apr 30 at 6:15
  • @DavidAnderson: Those are all possibilities, but it means setting things up, which takes time and I'm hoping for a simpler method. As for the Terminal - will it reformat a drive the OS sees as mounted and in use? I know Disk Utilities won't do that.
    – Tango
    Apr 30 at 7:30
  • You are trying to unmount the internal drive. As long as macOS Recovery does not reside on the this drive, then you will be able to unmount the drive. When booting macOS Recovery from the internet, you will be able to unmount the internal drive. When booting from a USB flash drive macOS installer, you will be able to unmount the internal drive. Apr 30 at 8:02
  • @DavidAnderson: Odd. I did get it to work - while working from the external drive, but this was a replacement drive, so it might not have macOS Recovery.
    – Tango
    May 1 at 3:56
  • I also have a late 2013 iMac running Catalina on a USB SSD. I often use the Disk Utility to unmount the volumes on the internal 1 TB HDD. I think this makes the Mac run faster. I have never had the problem described in your question. May 1 at 5:00
1

Can you try boot in Safe Mode (press Shift key when boot) and retry with the terminal : Below adapt the name of internal Drive with diskutil listcommand, try :

diskutil umountdisk force diskX

If ok you can reformat this internal disk. Keep in mind that the system need an internal disk with a EFI partition (formatted GUID) because it's the only way for future Firmwares Updates.

7
  • It forced me to change to APFS for this update, but from what I've read, since this iMac is from late 2013, I don't think I can update any more, other than security updates. From what I've read, Big Sur only works on Macs from 2014 on. I'll be trying this tomorrow, since it's late and I don't want to be half asleep. One thought is that if I force it to unmount, and since I'll be formatting that drive anyway, that deleting or changing the name of that dock tile may also work.
    – Tango
    Apr 30 at 7:32
  • I've the same Mac and you can have future Firmwares Updates. I've test Big Sur on this Mac and it's ok (with patch ;-))
    – Jean_JD
    Apr 30 at 7:52
  • Did you test Big Sur by doing a normal update through the preferences or did you have to do more? (Like the patch you mention?)
    – Tango
    May 1 at 3:55
  • @Jean_JD: I also have a late 2013 iMac running Catalina on a USB SSD. I have heard of [Patched Sur]. Is this what you used or something else? May 1 at 4:54
  • @David I've use this one : big-sur-micropatcher-0.5.1 from Github. ;-)
    – Jean_JD
    May 1 at 5:00
1

[This answer cropped up earlier in the week for a totally different question, but it seems appropriate again here…]

I would be more inclined to prevent the volume from mounting in the first place, then it won't need to be ejected.

You can prevent it from mounting using fstab.
I wrote an earlier answer on using this, so I'll link to that rather than covering the same ground again. The question itself is entirely unrelated, but the answer contains step by step for fstab

Time Machine restore to new partition, different computer

1
  • I'm going to look this over more tomorrow, when I'm not tired! I'll probably be trying the other answer (to force it to unmount) first, since, honestly, it's fast and easy. We'll know what works tomorrow!
    – Tango
    Apr 30 at 7:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .