0

Recently, the Finder has asked me for a password whenever I move a file to the trash. I get the message, "Finder wants to move 'filename' to the trash. Enter your password to allow this". I checked permissions on ~/.Trash, and it belongs to me/staff with drwx------ permissions, as expected. This happens with any file I try to delete, and I have full permissions on the files I'm deleting. When I enter the password, the file is moved to the trash (and not immediately deleted) as normal.

This is on Mojave 10.14.6, and it started happening after I installed security update 2021-003 (though I don't remember if it started happening immediately after that).

Note that I can move files to the trash from a command line. mv blah.txt ~\.Trash works just fine (no sudo needed). It's only when I drag a file to the trash that I have problems.

5
  • 1
    You have permissions on the FILES, or on the DIRECTORY containing them? It's the directory permissions that matter, not whatever the file is set to. Apr 28 at 21:17
  • Permissions on files and the directories they're in. And permissions on their parents, for good measure (though not on the root level of the startup disk, because Mojave doesn't like that).
    – the klaus
    Apr 28 at 21:43
  • Please provide the output of ls -l@ for the filename and the containing directory. Apr 28 at 21:50
  • Note that this happens for every file in every directory that I've tried. Here's a typical one: -rw-r--r--@ 1 me admin 163198 Nov 12 2015 my-file.txt com.apple.metadata:kMDItemDownloadedDate 53 com.apple.metadata:kMDItemWhereFroms 134 com.apple.quarantine 25 drwxr-xr-x 3246 me admin 103872 Apr 28 19:42 my-directory
    – the klaus
    Apr 28 at 21:57
  • Also, note that it works from a command line (details added to original post).
    – the klaus
    Apr 28 at 22:18
2

Ah, I found the answer elsewhere among many suggestions for fixing trash issues: just delete the .Trash folder. I ran sudo rm -rf ~/.Trash and restarted. The .Trash folder was recreated, and now it seems to work just fine. Odd. I'm glad it's fixed, but I wish I knew why the fix worked.

1

You can reset User Permissions on your "domain"

In the terminal application you paste this command :

diskutil resetuserpermissions / `id -u`

Then you reboot the system in safe mode (press Shift key at boot) and reboot after.

3
  • And what exactly does that do? It appears to be undocumented, and I'm reluctant to run it without some detailed information about what it does.
    – the klaus
    Apr 28 at 21:44
  • You can see here : eclecticlight.co/2020/02/18/… I used this command very often without problems.
    – Jean_JD
    Apr 28 at 22:02
  • Yeah, I'd found that article, but it doesn't actually tell me what this is going to do to my permissions. Is it going to set everything in my home directory to standard default values (me/staff ownership with -rwx------ permissions)? Is it going to mess with ACLs?
    – the klaus
    Apr 28 at 22:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .