3

After the last macOS update, a popup started appearing when you click on a misspelled word in Word for Mac. Popup for helping with spelling in Word for Mac

This is a very frustrating function when you work in several different languages not always wanting to spell-check even though the red underscoring is good as a reminder. Hence, I want to keep the previous functionality to get suggestions when right-clicking on an underscored word but would really want to turn this popup function off. Does anyone know how this could be done?

The only option I've found is to turn spell-checking as you write off completely, which also removes the red underscoring that I'd like to keep.

4
  • 1
    Latest macOS and latest Word. Don't observe described behavior. However, something does happen while using online Word i.e. in browser ('Click to view suggestions' -> popup window somewhat similar, but has 'Editor' as well) Apr 28, 2021 at 12:09
  • I can confirm that this does appear but not in every word version (possibly MS is a/b testing?). I have this on my personal mac but not on my work one, but I can't figure out why since they are both on the same office account (preview builds are not enabled)
    – mangecoeur
    May 19, 2021 at 7:58
  • I don't have an answer, but am seeing the same thing. Doesn't happen on my work laptop but does happen on my personal desktop. Both OS and Office are latest versions. Frustrating!
    – SCardinal
    May 28, 2021 at 22:37
  • I have the same problem. This is incredibly annoying.
    – Jim O.
    Aug 13, 2021 at 2:39

3 Answers 3

0

Just experienced this and I found the solution.

On Mac, goto

Word -> Preferences-> AutoCorrect (make sure you're on the AutoCorrect tab) 

and at the bottom un-check Automatically use suggestions from the spelling checker and this will remove that annoying new pop-up bubble.

However, the red squiggly lines will still be there and you can still right-click and see your options to fix the red squiggly lines (just like how it used to be before this update).

1
  • Sadly, did this not work for me. Unchecked the box you suggested and even restarted Word, but the annoying pop-up bubble that literally drives me nuts are still there...
    – Johannes M
    Jun 28, 2021 at 5:18
0

Deselecting this worked for the spelling suggestions box, but not grammar (I still get those popups...)

enter image description here

0

Go to preferences > View and untick comments on rollover enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .