1

as by subject -- I have lost track of what the latest CL Tools are available for Mojave (MacOs 10.14.x). I have

pkgutil --pkg-info=com.apple.pkg.CLTools_Executables
package-id: com.apple.pkg.CLTools_Executables
version: 10.3.0.0.1.1562985497

Are these the latest (obvs for Mojave, the very latest require MacOS 11 to install)? xcode-select seems to believe they are, but brew complains I could get newer tools (or, alternatively it is a bug in brew) so I am not sure which one to believe.

What brew complained (execute brew doctor to see it):

Warning: A newer Command Line Tools release is available.
Update them from Software Update in System Preferences or run:
  softwareupdate --all --install --force

If that doesn't show you any updates, run:
  sudo rm -rf /Library/Developer/CommandLineTools
  sudo xcode-select --install
 
Alternatively, manually download them from:
  https://developer.apple.com/download/more/.
You should download the Command Line Tools for Xcode 11.3.1.
2
  • How does homebrew "complain" about the version of the CLT you have installed? May 15, 2021 at 23:37
  • It adds a warning -- but this was so long time ago that the chances of me fishing out the exact words are 0 May 17, 2021 at 6:22

1 Answer 1

0

According to XCodereleases the last release of Xcode running in 10.14 is 11.3.1.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .