I have a Boot Camp problem. Both OSes boot correctly, but when I'm in OS X, I can't access my Windows partition and vice versa. I know that I can't write, but it should be able to read. But I can't access the partition at all.

In disk utility, I can see a disk0s4 grayed out where my Boot Camp disk should be.

To add, I tried to go with a 3 partition setup (OS X, Windows 7 and a data disk). This is after a clean Lion installation.

Here are additional details on my setup in case it helps narrow things down:

  1. Installed a clean version of Lion after installing a new HDD.
  2. Using Boot Camp assistant to install/setup Windows partition.
  3. Before installing Windows 7 I created a new partition.
  4. Restart and install Windows 7 from CD/DVD.

diskutil list shows:

  GUID_partition_scheme                        *750.2 GB   disk0   
                    EFI                         209.7 MB   disk0s1
              Apple_HFS OS X                    270.0 GB   disk0s2
              Apple_HFS DROPZONE                208.9 GB   disk0s3
   Microsoft Basic Data                         270.8 GB   disk0s4**
  • How was the data partition created: from OS X or from Windows installer? Can you run diskutil list from a Terminal window and add that detail to your question?
    – Vlad
    Feb 27, 2012 at 21:06
  • If you're using TrueCrypt it's normal behaviour for Windows to not recognize your OS X partition. What options are available in Disk Utility's contextual menu for your greyed disk0s4 partition? It could be that it's not mounted.
    – Vlad
    Feb 27, 2012 at 21:10
  • TrueCrypt? No I don't think I used that. I basically just installed windows, and all the updates that comes with win update ;) Feb 27, 2012 at 21:17
  • did you install NTFS-3G?
    – Am1rr3zA
    Feb 27, 2012 at 21:39
  • 1
    diskutil info disk0s4 will give detailed information about your partition.
    – Vlad
    Feb 28, 2012 at 8:05

3 Answers 3


NTFS support was removed in Lion, follow below to re-add it (you should be able to write to the drive as well, after installation)

install and enable ntfs-3g: http://www.macupdate.com/app/mac/24481/ntfs-3g/

and install fuse_wait: https://github.com/bfleischer/fuse_wait

  • I'm pretty sure this is wrong. I doubt they removed NTFS read support in Lion.
    – Cajunluke
    Aug 20, 2012 at 17:10
  • I have 16 apple computers and 30 NTFS harddisks (at work naturally) that all say NTFS support is removed from Lion, however I'll happily agree that Apple disabling NTFS is stupid.
    – Born2Smile
    Aug 29, 2012 at 21:44
  • I'm absolutely gobsmacked that they removed it. I guess maybe it got to be too much to support and the people who actually used it wanted read/write support, so they were using NTFS-3G anyway.
    – Cajunluke
    Aug 29, 2012 at 21:50
  • Yeah, me to. The rumor I heard about it was that they were planning to include NTFS read/write support in Lion, (previous versions of OS X had only read support), but the implementation wasn't stable, and so they disabled it last minute. Apparently the Lion pre-release beta had read/write support of NTFS
    – Born2Smile
    Aug 29, 2012 at 22:55

It appears that OS X is not mounting the Windows NTFS partition. This is probably for one of two reasons: either there is something wrong with the NTFS driver for OS X, or there is something wrong with the NTFS partition. What happens when you select the NTFS partion and click "File->Mount" in Disk Utility?

If you have not installed any OS X software like NTFS-3G which modifies the built-in NTFS driver, the problem is probably with your Windows partition. You can have a state where Windows will still boot from the partition, but the NTFS driver for OS X will detect that NTFS was not unmounted cleanly and left the partition in an inconsistent state and refuse to mount it.

In that case, you should reboot to Windows, and check the disk for errors (chkdsk /F). Then see if you can mount it in OS X.


It is solved! You can find the solution here:


Basically, I had same problem that I could not see my BOOTCAMP partition in MAC OSX. I had "Paragon NTFS read/write software" and this was the problem. When I searched for it in my mac spotlight (it is in top right corner of your mac environment) it was there. I opened it and chose "Turn the Paragon for mac OSX driver off" and then restarted my mac. Then the Bootcamp will appear again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .