1

My goal is to share files on Machine A (my MacBook Pro running Big Sur version 11.2.3) with other Macs on my home network. My understanding is that I must/should do this via SMB, but if it's possible/preferred to do using AFP or some other Finder-accessible approach (as opposed to command-line tools like scp), I'm open to suggestions.

At this point, I can't even access the files via SMB from Machine A itself.

Here are the variations I've tried so far to set up sharing. Use the Sharing pane in System Preferences to:

  • Simply turn File Sharing on with nothing listed under Shared Folders and no accounts checked under Options...->Windows File Sharing
  • Turn File Sharing on with a single folder owned by an admin account listed under Shared Folders (with 644 permissions selected) but no accounts checked for Windows File Sharing
  • Turn File Sharing on with nothing listed under Shared Folders and an admin account checked for Windows File Sharing
  • Turn File Sharing on with a single folder owned by an admin account listed under Shared Folders (with 644 permissions selected) and an admin account checked for Windows File Sharing

Here's what I've tried so far on the client side:

  • In the Finder, use Cmd-K (Connect to Server) to connect to smb://[Machine] or smb://[Machine]/[ShareName] or [Machine], where [Machine] is 127.0.0.1, an IP address for Machine A, localhost, the name of Machine A, or the name of Machine A with ".local" appended.
    • I am never prompted to enter a password.
    • This results in an error dialog with the message "There was a problem connecting to the server ... The server may not exist or it is unavailable at this time. Check the server name or IP address, check your network connection, and then try again."
  • In Terminal, run mount_smbfs //[Machine]/[ShareName]/ /Volumes/[NameOfEmptyFolder] or mount -t smbfs '//[Machine]/[ShareName]' /Volumes/[NameOfEmptyFolder].
    • I am prompted to enter a password in each case.
    • This results in the error message mount_smbfs: server rejected the connection: Authentication error (and also mount: //Machine]/[ShareName] failed with 77 in the case of the mount -t command).

I've even tried rebooting once and repeating all of the variations above, with the same results. I've gotten file sharing to work on this computer in the past, but this is my first time in quite a few months I've needed to do that again. Upgrading to Big Sur is the most obvious difference from before, but there are probably other differences I'm not thinking of.

Does anyone have suggestions for how I can get file sharing to work?

3
  • macOS 11.x can file-share only via SMB, so if the "server" machine is running Big Sur, it is indeed correct that SMB is mandatory (and AFP not an option). Have you tried accessing the "server" machine from a different Mac or iOS device (in the same network)? I'm pretty sure that a SMB network connection to the "own" machine is not possible on macOS. If you enable the display of "Bonjour computers" in the Finder sidebar, you will see that this will show only remote machines with file sharing services enabled, not the local machine.
    – Gummibando
    May 3 at 15:52
  • Thanks for all of the information and the suggestion. My initial attempts to connect were from another Mac on the network, but once I started varying the server-side settings, I stopped testing from a separate machine. At the time, I thought I was moving to a simpler case by eliminating the network, but it sounds like that actually made it an impossible case. This weekend I'll try connecting from another Mac while varying the settings on the server.
    – kenbur
    May 5 at 12:59
  • @Gummibando, I've confirmed that sharing via SMB is working now for each of the settings I've tried as long as I connect from another machine. Since that was not working before, my best guess is that the reboot fixed whatever was preventing sharing from working. Thanks for your suggestion, which solved my problem!
    – kenbur
    May 7 at 15:19
-2

Filesharing, screensharing, printersharing. It's all native in MacOS. Open up System Preferences, Go to the sharing tab. More information on how to tweak and more on the Apple-site. Want to share *nix or Windows machines? It's possible with Samba, Windows has smb build-in. Don't know all the details but Google for tuts or instructions. Be sure to read some actual information. In the past many different (and obsolete) ways were supplied. For example a Raspberry Pi (Debian Linux) https://kremalicious.com/raspberry-pi-file-and-screen-sharing-macos-ios BTW you have to set up sharing on all machines you want to connect.

1
  • Not sure how this answer addresses the problems listed in the question. The OP seems to know how to enable and use SMB, so general advice is probably not what they are looking for. Please have a look at apple.stackexchange.com/help/how-to-answer for some insights into what we are looking for in answers.
    – nohillside
    Jul 31 at 11:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .