I have a 2009 MacBook which I'm trying to factory reset/re-install. I have a USB bootdisk but sadly holding option to boot from USB doesn't work - I don't believe these models support it (A1342). It is definitely Intel (MacBook7,1, boot rom version MB71.0039.B0B). The Mac currently has Snow Leopard (OS X 10.6.8) installed.

Is there a way to load up and use the USB drive in an alternative manner? For instance from within singe user mode, or using a third party DVD bootdisk that will then, in effect, retro-fit the USB boot?

Or alternatively, is it possible to partition the main drive to create a recovery drive in some way?


3 Answers 3


A search for A1342 by everyman.com results in the following Macs:

You have a conflict in your question. A 2009 Macbook would have a ID of MacBook6,1, but you state a ID of MacBook7,1, which is a MacBook (13-inch, Mid 2010). You state an EFI Boot ROM version of MB71.0039.B0B. There appears to be an update to MB71.0039.B0E for the MacBook (Mid 2010), which requires at least Mac OS X 10.7.2 to install. According to this Apple website, this update would give a MacBook (13-inch, Mid 2010) the ability to use Internet Recovery and thus an alternate method of reinstalling OS X/macOS.

It would be very remiss of me not to mention Tetsujin's answer to the question How can I download an older version of OS X/macOS?

There is also the Apple websites How to get old versions of macOS and How to create a bootable installer for macOS.

Regardless of whether your Mac is a 2009 or 2010 year model, the maximum macOS that can be installed is High Sierra (macOS 10.13.6). The pre-installed OS X was Snow Leopard (OS X 10.6.1 or OS X 10.6.3), so you would not be able to use an USB installer created from the original Snow Leopard (OS X 10.6) DVD.


One path could take which would not use any USB ports are as follows. (Although, you should be able to use your USB ports if they are not broken.)

  1. Backup important files. If you can not use an USB port, then use the internet to transfer files to another computer.
  2. Click on the OS X El Capitan 10.11 link given in this answer to download the file InstallMacOSX.dmg. This file is 5.78 GB in size.
  3. Run the Install OS X application to create the Install OS X El Capitan application in the Applications folder. This should open automatically. If not, then open the InstallMacOSX.dmg file and then open the Install OS X application. The Install OS X El Capitan application will take 6.22 GB of space.
  4. From the Finder application, eject the Install OS X volume. Put the InstallMacOSX.dmg file in the Trash and empty the Trash.
  5. (Optional) You probably should try to create an USB El Capitan installer by following these instructions. This USB drive could be used to do a clean install, if something goes wrong. If you can not create the USB installer, then skip this step.
  6. Open the Install OS X El Capitan application to upgrade to OS X El Capitan 10.11
  7. Update the firmware. This step may not be necessary, since installing Sierra and/or High Sierra will also upgrade the firmware.
  8. Again use this answer to upgrade to High Sierra. If you can not upgrade to High Sierra, then upgrade to Sierra. After upgrading to Sierra, you should be able to use Internet Recovery to upgrade to or do a clean install of High Sierra.
  • You're right, it must be the mid-2010. Sadly I went to the update page and tried both the EFI and SMC updates for MacBook 7,1 and both say "This software is not supported on your system" (MB71.0039.B0E (EFI 2.1) and 1.60f6 (SMC 1.5) respectively) Apr 24, 2021 at 17:03
  • 1
    As stated in my answer, you need to have at least OS X 10.7.2 installed before updating the firmware. You answer states you currently have OS X 10.6 8. installed. Apr 24, 2021 at 19:15
  • Thanks David, this has been really helpful. I've got to the Yosemite installation up to the point where I enter the icloud information. As this is a new Apple account, when it gets to the "Signing in to the App Store ..." bit, I see the error "This item is temporarily unavilable. Please try again later". I have read about clicking the find help online button to open Safari, but icloud (and other Apple sites where I login) won't load in that session as much as I try - they just timeout (seems like it's almost blocked from loading). Any ideas? Apr 24, 2021 at 23:23
  • Which item is temporarily unavilable? Apr 24, 2021 at 23:26
  • 1
    I don't think he knows Apr 24, 2021 at 23:55

Any Intel Mac should be able to boot from USB. So the possibilities are:

  • that this particular Mac can't boot at all
  • that the USB disk is not configured correctly.
  • that the USB port is damaged.

Make sure that the USB drive uses the GUID partition map (not Apple Partition Map, nor Master Boot Record).

Make sure the OS on the boot disk is an OS that supports that hardware: - macOS 10.6.1 (Snow Leopard) to 10.13.6 (High Sierra).

  • I read that some don't boot from USB, including this 2009 model. However it is definitely Intel (MacBook7,1, boot rom version MB71.0039.B0B). I'll try some alternative usb boot disks, thanks Apr 24, 2021 at 13:07
  • There are Intel Macs that can boot from USB drives which use Apple Partition Map and/or Master Boot Record. However, the operating system may not necessarily be OS X or macOS. Apr 24, 2021 at 14:18
  • 2
    @LeonardChallis I've definitely booted 2009 MacBooks from USB. I suspect whatever you read is mistaken, but I'd be interested to see the link.
    – benwiggy
    Apr 24, 2021 at 14:20
  • This is not the first time I've heard that early Macbook Airs can't boot from USB. forums.macrumors.com/threads/high-sierra-mojave-on-2gb.2282413/… Apr 25, 2021 at 0:33
  • @Wowfunhappy It's not an MBA. That's a fairly oblique reference. This one says that MBAs were the first of all Mac laptops to USB boot. ("Dan's" answer) ifixit.com/Answers/View/504272/Why+cannot+my+mac+Boot+a+USB I could be wrong, but I think I even USB booted old PPC Macs.
    – benwiggy
    Apr 25, 2021 at 7:43

To address your final question about partitioning the main drive.

I have always used this technique when faced with USB boot issues:

  • Add a new partition on the main drive - it has to be large enough to hold the contents of the install DVD
  • Using Carbon Copy Cloner, copy the install DVD to the partition.
  • Finally reboot, using the new partition containing the installer as the start up disk (either via the Settings: Startup Disk control panel or holding Option during reboot).

FWIW, I have a MacBook 3,1, 6,1 and 7,1 and this technique worked on all of them.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .