1

ALL,

I apologize for this question - it seems that on the SO nobody develops under Mac, so I'm terying to ask here. If you suggest a better place to ask the question and get the answer - I'm all ears.

I have an old Mac laptop where I started my program, which contains of one binary and couple of dylibs. That Mac has OSX 10.8 with appropriate Xcode. Everything worksd correctly there. I'm building the program and can run it from the Terminal as well as from inside the Xcode.

Relatively recently I bought myself a newer Mac laptop with OSX 10.13, installed Xcode, grab my sources from the github and all libraries it depends on, compiled everything (successfully), and tried to run it from the Xcode. That execution immediately failed and it stopped somewhere inside the assembly code even before it hit the initialization routinme of my code (C++). So I tried to run the program from the Terminal and the run was successful.

I didn't try to change anything inside the projects.

I suspect that the newer Xcode changes the way dylibs are handled and now I will have to rebuild the whole Xcode solution from scratch, but I really want to avoid that if I can help it.

So my question to you is - is there a way to set a new machine with the new Xcode so that I can run my project from inside the Xcode?

TIA!!!

1
  • I'd expect Xcode to give some hint why your program doesn't run... What messages are logged, if any, in the Debug Area (display it with View > Debug Area > Show Debug Area)? Are there any messages in the Issue Navigator panel on the left-hand side of Xcode's main window (display it with command-5)? If that's the case, could you add them to your question?
    – jaume
    May 1, 2021 at 10:41

0

You must log in to answer this question.

Browse other questions tagged .