0

Mail.app 14.0, macOS 11.2.3, IMAP email account.

I'm subscribed to several mailing lists and have Mail.app rules that sort mail from the list servers into specific mailboxes.

About one half of the list mail from the servers is correctly sorted, while a significant proportion isn't. If I select the unsorted mails in Mail.app's Inbox, then Mail > Message > Apply Rules, the unsorted messages immediately move to the correct specified mailbox. In all other respects, Mail.app runs correctly and quickly.

My setup uses Spam Sieve, but these Rules are below the Spam Sieve rule in Mail.app's Rules list, so SS has already done its exam and, I think, isn't involved in this oddity. The only Rule that runs an AppleScript is the Spam Sieve "Remote Training" Rule, which appears on the Rules list above the Spam Sieve Rule. The non-sort behavior also occurs if the machine (an iMac) is in Safe Mode.

The same issue has been asked about here and here. As suggested, I discarded all the rules, then quit Mail.app, restarted the Mac, and then recreated the rules from scratch. The same behavior continues.

Any idea what's going on here, or how I might improve Mail.app's performance?

10
  • Do you have iCloud sync on? If you don't have multiple Macs, switch it off.
    – Tetsujin
    Apr 22 '21 at 16:19
  • 1
    @Tetsujin Thanks. I don't use iCloud for synching emails. I do have iCloud synch turned on (desk Mac, carry-around-travel Mac, iPhone), but only as to Safari, Keychain, Contacts, Find My, Desktop/Documents and a few other services; the Mail checkbox (on all my devices) in System Preferences > Apple ID > iCloud is not ticked; I rely on the IMAP server for synching emails. Apr 22 '21 at 16:27
  • OK - it is noted as being problematic in the Spam Sieve manual, so thought it worth mentioning.
    – Tetsujin
    Apr 22 '21 at 16:29
  • It might be worth checking through each Rule to see which can be set to 'Stop evaluating rules' to lighten the overall load.
    – Tetsujin
    Apr 22 '21 at 16:35
  • 1
    @Tetsujin That's easy enough to add, particularly to the Rule that invokes the SS training AppleScript. I'll give it a try. Thanks again. Apr 22 '21 at 16:36
0

The issue was mine.

I deleted all the existing rules, and remade them from scratch. Some new rules didn't work well at first, but I modified the conditions (adding a condition with a problematic email selected creates a condition based on that email's attributes) and then used the "Apply Rules" selection from the "Message" menu to test their effect.

After a few days of testing, sorting is now almost always correct, and immediate.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .