0

I bought an Macbook 12" 2016 which doesn't want so sleep when I close the lid. Furthermore it also doesn't want so start if I open the lid. I tried resetting the SMC and NCRAM, then I reinstalled MACOS. Nothing helped. I also tried to get it so sleep with magnets, this worked out quiet well, so I don't think that the sensors are broken.

Here is my pmset -g output:

System-wide power settings:
Currently in use:
 lidwake              1
 autopoweroff         1
 standbydelayhigh     86400
 autopoweroffdelay    259200
 standbydelaylow      10800
 standby              1
 proximitywake        0
 ttyskeepawake        1
 hibernatemode        3
 gpuswitch            2
 powernap             0
 hibernatefile        /var/vm/sleepimage
 highstandbythreshold 50
 displaysleep         2
 sleep                1
 acwake               0
 halfdim              1
 tcpkeepalive         1
 disksleep            10

and my pmset -g assertion output:

Assertion status system-wide:
   BackgroundTask                 0
   ApplePushServiceTask           0
   UserIsActive                   1
   PreventUserIdleDisplaySleep    0
   PreventSystemSleep             0
   ExternalMedia                  0
   PreventUserIdleSystemSleep     0
   NetworkClientActive            0
Listed by owning process:
   pid 142(WindowServer): [0x0000001800098047] 00:00:00 UserIsActive named: "com.apple.iohideventsystem.queue.tickle serviceID:100000271 name:AppleHIDKeyboardEve product:Apple Internal Keyb eventType:3"  
    Timeout will fire in 120 secs Action=TimeoutActionRelease
No kernel assertions.
Idle sleep preventers: IODisplayWrangler

Thanks for your help!

0

Your power management settings are excellent. If you say you've already reset all of the controllers that could be causing this problem, then it really could be a hardware failure.

I just don't quite understand how you notice that the computer is not sleeping? In the settings of pmset no process prevents sleep?

My final advice would be to switch to Hibernatemode 25

sudo pmset -a hibernatemode 25
2
  • I noticed it because I played a YouTube video and closed the lid, and the music goes on. – Launch_Control Apr 18 at 10:04
  • Setting hidernatemode to 25 doesn't helped either, but thanks anyway :) – Launch_Control Apr 18 at 10:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .