1

I have an Apple Watch Series 3 and MacBook Pro 2017. I tried pairing my Apple Watch to my MacBook and it worked, but I can't use it for login. I can only use my Apple Watch to authenticate within apps (ie. in the security tab of system preferences, I can click the lock icon and unlock it with my Apple Watch). I can't use my Apple Watch to unlock the MacBook. Does anyone know how to fix this?

8
  • What version of macOS is running on your MBP, and which version of WatchOS is running on your Apple Watch 3? The MBP needs to be running High Sierra or later.
    – IconDaemon
    Apr 14 at 18:10
  • Sorry, forgot to put that. I'm running Big Sur on my MBP and watchOS 7.3.
    – Salocor
    Apr 14 at 18:11
  • This document at Apple Support states: "Your Mac and Apple Watch are signed in to iCloud with the same Apple ID, and your Apple ID is using two-factor authentication." Perhaps you have not enabled 2FA for you Apple ID?
    – IconDaemon
    Apr 14 at 18:15
  • Yeah I do. Good thought though. The weird thing is that it works within apps.
    – Salocor
    Apr 14 at 18:17
  • 1
    I figured it out!!! So I unpaired and repaired my watch, but that didn't fix it. While I was doing this, I noticed I had an update on my watch. After the update, everything is working great! Thank you for the help! Not sure I would have ever noticed there was an update without you! :)
    – Salocor
    Apr 22 at 0:18
1

Well I thought I figured it out, but it stopped working shortly after. So after much troubleshooting, I really did figure it out. Wifi has to be enabled on the Apple Watch for the unlock to work.

It's funny that none of the apple support documents say that. I just use bluetooth on my watch, so I tend to keep Wifi off. When I reset my watch, Wifi was automatically turned back on, which would explain why it worked for a while.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .