5

Similar to There is no application set to open the URL rstf3://, I am getting the following error when clicking on https://miro.com/* links from another application (Slack):

There is no application set to open the URL miroapp://

There is no application set to open the URL miroapp://

I uninstalled the miro desktop application "as clean as possible" with AppCleaner but I am still seeing the issue after rebooting my MacOS (latest).

I also checked with SwitfDefaultApps but I can not find any association related to miroapp.

Would be great not to have some funky workaround but really fix the root cause. Surely this is some simple setting somewhere? I think with windows this would be the registry/regedit.

I do not want to have the miro desktop app installed.

3
  • What exactly are you doing that generates this dialog box? What version of macOS are you running? (Looks like macOS Big Sur) Is the app in question Miro Desktop from https://miro.com/apps/? Commented Apr 14, 2021 at 14:35
  • To extend off of that, this alert is what happens because you uninstalled the application, then tried to open a link that relied on the application. Knowing what you were doing is critical to understanding why you're seeing this alert.
    – Ezekiel
    Commented Apr 14, 2021 at 16:30
  • Thanks good feedback, completely forgot about mentioning how I am getting the issue 😅 Commented Apr 14, 2021 at 18:25

2 Answers 2

12

Miro actually has a Help article to solve this issue: https://help.miro.com/hc/en-us/articles/360019244239-How-to-Disable-Miro-Desktop-App-Pop-up-in-Your-Browser

Here's the important steps:

For Mac users

Step 1. Delete (uninstall) the Desktop app from your computer.

Step 2. Rollback the setting ‘Always open URL in the Miro App’ in your browser. Here's how you can do that in Chrome and Firefox. For Chrome:

  • Close all Chrome + Miro windows before starting (use Cmd + Q to quit the browser)
  • Open a finder window > press Command + Shift + G > enter the following path into the search box: ~/Library/Application Support/Google/Chrome/Default/Preferences.
  • Open Preferences in a text editor Search for https://miro.com":{"miroapp":true}
  • Remove https://miro.com":{"miroapp":true} Save changes Restart Chrome browser.

If you use several Google profiles, you will need to edit Preferences in all catalogs. For this, on step 2, you will need to open ~/Library/Application Support/Google/Chrome and change Preferences in folders Profile 1, Profile 2, etc.

3
  • 1
    While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes.
    – grg
    Commented Jun 9, 2021 at 21:50
  • 1
    @grg thanks for the tip! I've added the important info to my answer. 👍🏻 Commented Jun 10, 2021 at 23:45
  • @DanielMargheim thanks for this! Fixed my issue with MS Teams on Brave Browser, too :-)
    – dkapitan
    Commented Nov 2, 2023 at 8:16
0

For anyone who's trying to fix that for the Arc browser, here is the path to the Preferences file: ~/Library/Application Support/Arc/User Data/Default/Preferences

and continue with the steps described in the message above

New contributor
Madiyar is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
1
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented 2 days ago

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .