3

It seems like I have a desktop which is slightly larger than my screen. When I maximise a window the bottom portion (approx 300 pixels) and right portion (approx 200 px) are not visible. I can move the mouse to that invisible and perform click operations but the pointer is not visible on screen. (It is shown when in the visible region). Attempting to scroll beyond the visible extremities does not pan the screen.

See the attached screen shots. For the truncated ones, I captured a portion of the visible regions, starting at the top of the screen and moving to the right-most visible (or bottom most). For the non-truncated ones I moved the mouse enough such that I could be confident of being at the extremity of the desktop - but I had to do this unseen.

Horizontal truncation: visible portion of status bar, showing horizontal truncation

full status bar

The same thing happens with vertical truncation, but the images take up a lot of vertical space in this post and don't really add much (though I can add them if this is desired).

I've had to move the Dock to the left of the screen in order to make it visible but I would prefer to keep it on the bottom.

In terms of my machine setup:

I'm using a new 2020 issued M1 MacBook Pro running Big Sur. I've tried both with and without an external display. With an external display, that external display shows fine (and has no truncated region). But in both setups, the built-in display of the laptop is truncated.

In case it matters: I migrated my data to it from a 2015 edition MacBook Pro which had been upgraded to Mojave.

I've tried looking in System Preferences but don't see anything related to screen size in the Displays subsection. I've also tried looking for zoom/magnifying settings (such as might be used for a11y reasons), again to no avail.

I'd welcome suggestions for things to try here.

3
  • Intriguing. If you make a screenshot of the whole screen, how high/wide is it (in pixels)? If you boot into Recovery Mode, does it exhibit the same symptom? – Andreas Ley Apr 14 at 11:39
  • 2880x1800px. The lock screen did exhibit the same behaviour. Recovery mode did not; that worked as expected and desired, i.e. not truncated. – mattp Apr 14 at 12:26
  • I had the same thing happen last night with my 2020 M1 MacBook Air on a just-updated Big Sur. I'd previously connected to an HDMI display a couple of times without this happening, this time I was using a VGA display. Did this start for you only after you'd been using an external display? – hippietrail Apr 14 at 20:22
1

I believe the following happened:

Your MacBook display's native resolution is 2560x1600. However, the default setting on the 13-inch MacBooks is 1440x900@2x (making the UI slightly larger for better accessibility). What the MacBook is supposed to do:

  1. Render screen at 2880x1800 (to create 1440x900@2x)
  2. Scale down to 2560x1600

It seems your MacBook failed to do step 2 and just displayed the unscaled image natively, thereby truncating 320px vertically and 200px horizontally.

Although I'm not sure what caused this, the reboot into Recovery Mode might have forced a reset of the scaling settings, fixing the issue. Maybe choosing a different scaling for the display might have worked, too.

1

Previous reboots did not recover desired behaviour. But having checked the presence or absence of symptoms during Recovery Mode as per Andreas Ley's comment in my original question (behaviour was normal), I reboot again into normal mode and correct behaviour remained.

So I don't know specifically what was at fault, but an interim Recovery Mode reboot helped to remedy the situation.

0

I had the same problem with my 2020 M1 MacBook Air and a cheap Lenovo VGA monitor.

I didn't want to reboot so I set up my external display again and attached it back to the MBA. Some of the Windows appeared on the external screen but the built-in one was still "confused" about its resolution.

I went into the Display Settings and turned mirroring on and off a couple of times but this did not fix it. Since I've noticed removing a USB stick behaves differently if I remove it first from the USB-C adaptor vs together with the adaptor, I tried disconnecting and reconnecting the external display both from the USB-C adaptor still attached to the computer, and from the computer still attached to the display. I then turned mirroring off and on a couple more times. Finally I closed the lid for 30 seconds and opened it again.

The built-in display was now correct and stayed correct after disconnecting the external display.

This is not deterministic since I'm not sure which exact step or sequence of steps was the one that finally fixed the problem. If it happens again I'll try to narrow it down.

If this happens to anyone else, fiddling with these few things could fix it for you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .