3

I have a MacBook Pro (mid-2015) that I want to completely wipe.

2+ years ago, I installed my own 1TB SSD. Everything works completely fine, and always has; I can boot into the OS, it runs fast, plenty of space left on the drive (600+ GB).

But when I boot up with CMD+R to try disk utility, things get weird.

  1. It boots into Internet Recovery instead of MacOS Recovery.
  2. Once Internet Recovery loads (~5 minutes), Disk Utility doesn't show my 1TB Drive. Only the "disk0" & "OS X Base System."
  3. Reinstall OSX doesn't give me the option of selecting my 1TB drive, or any drive for that matter, given only the 1TB drive is installed. Plus, Reinstall OS X is trying to reinstall Yosemite (10.10) meanwhile the 1TB drive has Big Sur (11.1) installed.

Any idea why this is happening, or what I can do to wipe the drive? I have everything I need from it, so I don't need to salvage any data in the meantime. Preparing to give it away, and need to make sure my data is erased.

Things I've done:

  1. Reset SMC & PRAM (SMC a few times).
  2. Ran Disk Utility - First Aid on the disk while inside the OS.
3

1 Answer 1

3

Before I get to erasing your Mac, I have some recommendations for non-obvious steps to take before erasing it. Some of these are covered in Apple Support Document HT201065 ("What to do before you sell, give away, or trade in your Mac"), but I have a couple of additions:

  • Do you have Two-Factor Authentication set up for your Apple ID? Is the Mac the only second factor for it? If so, you'll save time and pain later if you set up some other second factor options before erasing it. Either sign into your Apple ID on an iPhone/iPad/other Mac and set that up as trusted, or log into your Apple ID at appleid.apple.com, go to the Security section and add a trusted phone number.
  • You may need to deauthorize the Mac in iTunes, and possibly any other subscription services that the Mac is authorized in.
  • Turn off Find My/Find My Mac, so the next owner isn't faced with an authorization-locked Mac.
  • Sign out of iCloud (in System Preferences) and iMessage (in Messages).
  • Unpair any Bluetooth devices that aren't going with the Mac (unless you don't have a wired keyboard and/or mouse for the rest of this process).

Ok, now for how to erase the Mac. It sounds like the problem is that your SSD is formatted with the new APFS volume format, but it's starting in an older version of Recovery that doesn't know how to deal with that format. There are a couple of ways to deal with this:

  • My recommendation would be to download the installer app, and use it to create a bootable installer flash drive. Apple's instructions are in HT201372, but there's one preliminary step missing: format the flash drive with a GPT partition scheme (most come with MBR instead):

    1. Run Disk utility, and plug in the flash drive you want to use.

    2. Choose View menu > Show All Devices.

    3. Select the flash drive (not the volume(s) listed under it).

    4. Click the Erase button. You should see an Erase dialog with Name, Format, and Scheme options. If Scheme isn't there, you may've selected a volume instead of the entire drive; back out and try again.

    5. Leave the name "Untitled", set the Format to "Mac OS Extended (Journaled)" and the Scheme to "GUID Partition Map".

    6. Click Erase and wait for it to finish. If it fails (it does sometimes), try erasing it again.

    7. Once it's successfully erased, quit Disk Utility and run Terminal instead.

    8. Run the createinstallmedia utility in the OS installer. The command will be something like:

      sudo /Applications/Install\ macOS\ Big\ Sur.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled
      

      (See the Apple Support Document if it's something other than Big Sur.)

    9. Enter your admin password (it won't echo), follow the prompts, and wait for it to set up the drive.

    10. Once that's done, you should be able to select the drive in System Preferences > Startup Disk pane, then restart your Mac. If that doesn't work, restart and hold Option (note: it'd be the power button on an Apple Silicon Mac) to get the startup manager, and select it there.

  • If you don't want to do that (or don't have an erasable flash drive available), try restarting with Command-Option-R held down. That should get you Internet Recovery using the latest version of macOS that's compatible with your Mac (Big Sur at this point), and its Disk Utility should know how to deal with the APFS volume.

The installer drive is a bit more work, but it gives you a lot more options if anything (else) goes weird during the process, so (again) I'd recommend doing that instead of the Internet Recovery method.

[EDIT: and as I was writing this, you apparently tried the second method and something else went wrong. According to this question, that might be due to a network problem. Try the installer disk method.]

3
  • Thanks Gordon -- trying this now, will report back soon.
    – Jim
    Apr 13, 2021 at 2:07
  • This did it! Had to fight through a couple broken USBs to find one that worked (my own issue) but was able to erase the 1TB volume, and now reinstalling Big Sur. Thanks Gordon!
    – Jim
    Apr 13, 2021 at 12:34
  • Very good Gordon!
    – BabyBoy
    Apr 13, 2021 at 15:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .