I have a MacBook (early 2009 model), and yesterday the SuperDrive stopped working.

On attempting to push a DVD into it, it is physically stiff and doesn't want to go in, with a lot of pushing it goes further, and the automatic mechanism tries to suck it in (or at least makes a noise), but nothing happens. On closer examination, it would appear that something is catching the disks around the middle of the entrance of the SuperDrive which is preventing them from simply gliding in as they used to. I'm unsure whether its something broken, or perhaps a locking mechanism that has somehow got stuck. I did think that something might be stuck in there, but I am not missing any DVDs and I have tried restarting holding down the mouse button to eject, and while it makes the eject noise (which sounds healthy), nothing comes out.

I have tried all the obvious things - resetting the PRAM and SMC, to no avail.

I don't imagine that anyone has a fix for this as its probably a physical problem, but I thought I'd try as I am not currently near an Apple shop and I don't particularly want to be without my computer for too long, so I'd rather attempt to find a fix myself before doing anything else.

  • This probably isn't what you want to hear, but I have always had trouble with optical drives on Macs (including my own iBook, iMac, and current MacBook Pro. I just bought a USB optical drive and I use it whenever the built-in gets flaky (which is always). Other than that, I just do my best to do without optical media entirely. Again, not a solution, but it sure is easier to spend $20 on an external drive that always works with any current or future computer, Mac or PC. – iynque Jul 20 '12 at 18:01
  • So - what ever happened? Can we help further? – bmike Jan 25 '13 at 0:31

I just had this problem with my 17" mbp early 2009. ODD was blocked like there was disc already in, but of course there wasn't. Tried many times SMC & PRAM reset and Force shutdown. Sometimes the drive clicked and I managed to insert one disc, which was read just fine. But after ejecting it, the block was again there.

Then googled some more and typed "drutil eject internal" few times in terminal and all was OK again.

  • 1
    open terminal and type: drutil tray eject I had to do that several times to unlock the mechanism again. And then it worked again but I have to replace the drive. He can't read anything. – user67158 Jan 12 '14 at 13:54
  • This eject command might work a few times, but it doesn't fix the underlying problem which will get worse over time and then eventually fail totally. It is free and quick and doesn't really do any more damage than is already present, so give it a shot before seeking repair. – bmike Jan 12 '14 at 14:02

Take a photo of (or examine closely) the side of the MacBook - usually a difficult insertion is caused by a bend in the body. Most photos of iPhone 4 quality will show that clearly. The eject lever can also flip into the closed position, so in that case you'll need to get inside the drive mechanism itself to reset the mechanism or replace the drive.

The repair for this is quite rapid, and if the shop has your drive in stock, ask about waiting for the repair if possible. Worst case they can diagnose what it needs and confirm the part and you can ship the Mac for repair at a time more convenient to you.

  • 1
    +1 … a few months ago my MacBookPro5,2 was dropped enough to pop out the base at the corner opposite the optical drive. A few weeks ago I found it impossible to insert a disc, the issue was transient. – Graham Perrin Mar 30 '13 at 14:19

I don't think it will make the eject noise unless the drive is registering that something is in there (my 2011 doesn't, tried holding eject button on restart). Do you have any children in the house? You may not be missing any DVDs but how about business cards or other portable objects?

I would reach for the screwdrivers, and so armed go look at the Unibody MacBook Pro teardown at iFixit. I hope I've linked the right guide but you should be able to find the right one if it is not. Once you have the optical device removed it should be easy to clear whatever is in there. Fortunately the optical drive is fairly easy to access.

You will at least be able to decide whether the drive is out of alignment with the external slot, or whether the drive mechanism has a fault.

  • This was my first thought too: Any kids in the house? It really sounds like something is stuck inside. – iynque Jul 20 '12 at 18:06
  • Back in the days of 3.5" floppies I had a friend call me because his disk drive wasn't working. Turned out his son put a graham cracker in the slot. It was the perfect size. – SSteve Jul 20 '12 at 18:29

Here's what worked for me on a 2009 17" MBP: As suggested above, and with the computer turned on it's end with the disc drive in the air, I forced a disc in - not all the way, only as far that I could still pull it out manually, I pulled it out and nothing changed, but I then opened Terminal (located in Utilities folder, which is inside the Applications folder) and typed "drutil eject" and hit return. The first time, I heard a click, but the drive didn't open. I typed it again and hit return and this time I heard a click and the drive did open. Upon reflection, this probably would have also worked while the disc was forced in, or if I had pushed it in all the way.


I now had the same issue. I read all the answers here. This worked for me: I typed "drutil eject" in Terminal several times. Every time the sound from the drive was slightly different as if the mechanism was stuck but starting to get loose. At the same time I gently pushed a disc inside the drive to help the mechanism to loosen. Suddenly the disc slipped without any force in and everything now works fine. I used the "drutil eject" command 11 times.


No body is going to like my answer. But after typing the command into terminal and it not working, i just took a blank dvd disc (that i don't care about) and just forced it into the drive. I know, I know, you bought a $$$$$ premium laptop, why do something so risky. But honestly, there is just a mechanism preventing the addition of new media in the drive bay because it thinks something is already in there. You gotta force the dvd up and wedge it in there so that the latch forcibly opens when you pull the disc back out. Your force the disc in, it catches the lip of the mechanism blocking entry, and when you pull the disc back out, it pulls open the flap. Not sure if anyone will do this, but it worked for me. No issues/sounds afterwards.

Of course it goes without saying, never force/shove a disc in when its normally working. It is delicate in the drive bay and you don't want to scratch the optical lense in there. We are just trying to get the flap to open, so only putting half the disc in there at most is sufficient to open it up.

  • I would encourage people to not do this unless they are willing to break the mechanism forever. I've been inside the drives themselves on dozens of times and inside Macs with broken drives multiple hundreds of times. Taking it to someone that can remove the drive is far, far better than trying to "trick" the mechanism into fixing itself since not always is the drive stuck in a recoverable position. This makes things much worse for most stuck drives. – bmike Dec 28 '14 at 20:14

shut down the Mac. Restart holding down the trackpad.... worked for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .