I am trying to get a Microsoft Sculpt Ergonomic keyboard to work with my MacBook Pro and while I found a couple of posts on similar issues, none of the suggested solutions worked for me, so I am posting this, hoping someone has a fresh suggestion:


My keyboard is skipping a lot of keys. I.e. some of the keystrokes do not appear in my editor/browser. Also moving the complementary mouse (connected to the same dongle) makes very sluggish moves on screen. It affects all keys. Occasionally, it starts working well for a couple of minutes and lagging usually starts when switching apps e.g. if I switch from OneNote to Firefox.


  • MacBook Pro (13-inch, 2020, Four Thunderbolt 3 ports) macOS 10.15.7
  • Microsoft Sculpt Ergonomic Mouse & Keyboard. They are wireless and connect to a Microsoft® 2.4GHz Transceiver v9.0
  • To connect the transceiver I use a 4x USB 2.0 to USB-C hub.
  • An additional wired mouse plugged into the hub

Troubleshooting so far

Following other posts, I tried the following on my mac:

  • turning it off and on again
  • turning bluetooth off on the macbook
  • disable handoff for icloud devices
  • disable slow keys and sticky keys.
  • use different usb ports (both usb c ports on the mac and usb ports on the hub
  • run sudo fs_usage | grep -v 0.00 to see if there is any kernel throttling happening.
  • disabled mouse keys

To rule out any issues with the usb dongle/hub or wireless signal jamming, I plugged the usb dongle into my Huwai MateBook (running Ubuntu), while I kept the MacBook running next to it. The keyboard works perfectly well on the other laptop.

  • Could you be specific about the missing keys? If it is 789uiojkl, that is a simple fix in accessibility preferences (turn OFF Mouse Keys). Commented Apr 9, 2021 at 12:41
  • thanks for the input. it is definitely including e, t and space key and mouse keys is off. I update the question Commented Apr 9, 2021 at 15:13

3 Answers 3


Same issue here, across a range of MacBooks (2017, 2020, 2021). The keyboard would intermittently skip keystrokes when the keyboard USB transceiver is connected via a USB hub (e.g. anker premium usb-c hub, choetech 7-in-1 usb-c hub).

It's not a complete solution, but the problem does not occur when the keyboard transceiver is connected directly to the MacBook (on older models pre usb-c), or via the official simple Apple usb-c to usb adapter, model A1632 (I have not tested the AV multiport one): https://www.apple.com/shop/product/MJ1M2AM/A/usb-c-to-usb-adapter

  • thanks for the suggestion!, could you specify which original adapter you have tested? I.e. the Apple USB-C Digital AV Multiport or the simple USB-C to usb adapter? Commented Jun 15, 2021 at 9:39
  • I switched to a belkin multimedia hub and it works as well. Thanks for the suggestion. I tried two hubs before that both had the issue. Commented Jun 17, 2021 at 12:04
  • edited original answer to indicate which adapter i tested
    – user587155
    Commented Jun 20, 2021 at 6:20
  • 1
    @BenjaminSchwetz could you share the very model of the belkin hub you tried? i'd be interested in trying it out.
    – user587155
    Commented Jun 20, 2021 at 6:25

Something I've noticed is that if I put either of my phones down on the desk close to the receiver then it starts to drop keystrokes immediately. Sometimes a phone can be between the two with no apparentl problems, but there's definitely immediate interference if I put the phone right by the receiver and I can reproduce that with ease.


I purchased a USB-C to USB-A from Apple that is A1632 and my sculpt works fine now... I had a J5create USB hub where I had the same issue mentioned above...

  • 1
    How does this answer differ from the answer already provided? It looks like you're just verifying the answer given works for you.
    – fsb
    Commented Jun 26, 2021 at 20:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .