1

I just got a new Mac and my contacts are not syncing in messages. I have turned off/on contacts sync on both the new Mac and my iPhone multiple times, but the issue persists.

Please note, not all my contacts are missing on my Mac, but most of them are. Certain contacts like my immediate family members are shown in Messages....not sure why. When I search in the Contacts app in my Mac, I do not seeing the missing ones. I can add them one-by-one, but obviously this is not a good solution.

How can I fix this?

EDIT: I'm on macOS Mojave and cannot upgrade yet because I must have some legacy 32-bit apps. However, iTunes has the sync functionality that was moved into Finder in Mojave (iTunes has been EOL'd, thankfully).

1

You can try following method

  1. Connect your iphone or iPad to your mac using a usb cable.
  2. Wait a few minutes and then open a new Finder window.
  3. Your device should appear in the Sidebar of your Finder window.
  4. Select your device and you should get a panel like the one below.

enter image description here

  1. Click on info on the top line of your panel.

This should give you options on which things to sync. This method is described in more detail at this location

5
  • Thank you!! Looks like it's going to work. I had to use iTunes BTW since I'm on macOS Mojave, but same concept, yes. I'll mark BA if it works... – SamAndrew81 2 days ago
  • how can I sync these contacts to iCloud so this never happens again...?? – SamAndrew81 2 days ago
  • 1
    Go to System Preferences. Click on iCloud. From there select contacts. All contact information should appear on icloud. – Natsfan 2 days ago
  • Syncing the contacts from my iPhone still has not made them show up on my Mac :( – SamAndrew81 2 days ago
  • interesting. i'll look into this and see what i can come up with. – Natsfan yesterday

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .