Good morning,

My MacBook 2016 with TouchBar doesn't boot anymore when going from its original Sierra to newer operating systems, e.g. High Sierra or Big Sur. One morning the computer just refused to boot, and got stuck in the login process. I was able to still log in, sometimes, but after opening an app, the Mac gave a kernel panic. Various tests later, reformatting the drive, and resetting everything, eventually I was able to use Internet Recovery, to install the original Sierra OS, which still uses HFS+. Naturally I tried installing Big Sur first, but got the same issues right after upgrading. I then tried going in steps, using gibMacOS, from Sierra, to High Sierra. But even High Sierra produced the same issues. I was in Disk Utility that installing High Sierra, already formatted the drive to APFS, so my conclusion now is that something makes the computer stop working after the converting to APFS.

Ideally I would love to get Big Sur again up and running, but I don't know what steps I can take to make that happen. My hunch is that some sectors on the drive are just so damaged, because of wear and tear that it's now impossible to get it formatted to APFS. I hope I'm wrong though.


MacBook refuses to boot after its drive gets converted to APFS it seems. Restoring Sierra makes the computer work again, but any upgrading attempts to High Sierra or Big Sur, resulted in the same issues the Mac had, which started this entire problem.

You must log in to answer this question.

Browse other questions tagged .