0

Automatic time synchronization sets the time with a difference of 6 seconds from the real time.

How is this possible? I probably set it wrong somewhere. But I can't figure out where.

If I set the automatic time synchronization in the system settings, the time becomes inaccurate. I've tried two servers time.apple.com and pool.ntp.org. I've tried running the commands:

% sudo sntp -sS time.apple.com                            
+6.140727 +/- 0.000153 time.apple.com 17.253.38.125
% sudo sntp -sS pool.ntp.org  
+6.122656 +/- 0.045479 pool.ntp.org 193.192.36.3

Using the sntp command and the system settings window I was able to set the time more or less accurately manually. I do not know how to set the time to an accuracy of less than one second.

I have no need to set the time accurately. But, my connection to Binance does not work. For some reason unknown to me, Binance requires sending accurate timestamp when working with site via REST API. And with time difference of 6 seconds, my requests are not executed.

Current operating system version Mac OS Big Sur 11.2.3 (20D91). As far as I can judge from the system settings, the connection to the Internet is via my home wifi router directly to the ISP without any additional proxy servers.

0

You must log in to answer this question.

Browse other questions tagged .