1

This all started because I was trying to clean install a Macbook Pro that someone sold me.

They gave me the password to log into the computer under their profile so I could clean install it.

I started the process of erasing Macintosh HD so I could reinstall macOS (Catalina).

While trying to erase, I was prompted for the previous user's password for their Gmail so they could be logged out of Find My Mac. The profile password didn't work for this.

I accidentally erased Macintosh HD - Data, and now the computer won't let me log in at all.

Here's what happens: I turn the Macbook on, it goes to the login screen like normal.

enter image description here

I enter the password that worked before, but now this happens.

enter image description here

And when I hit a key, I am sent back into the login screen.

enter image description here

And there's no way out of this loop except to go into Recovery Mode.

When I go into Disk Utility, this is what Macintosh HD looks like.

enter image description here

When I try to mount the Macintosh HD, I get this error.

enter image description here

I tried resetting the NVRAM, I tried doing internet recovery on Macintosh HD - Data. Nothing changed.

Any help I could get would be greatly appreciated.

New contributor
Jessifer Brandlefly is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
9
  • 1
    This all went wrong because whoever sold you it should have done all this before selling it… :\ They sold you a machine that's still locked. We need to know precisely what Mac it is - age plays a big part in this; how well it's locked. See support.apple.com/HT201065 – Tetsujin Apr 6 at 17:43
  • Oh shoot. That would be helpful wouldn't it. MacBook Pro (13-inch, 2020, Two Thunderbolt 3 ports) – Jessifer Brandlefly Apr 6 at 17:49
  • That's newer than my experience could answer, I'm afraid - but will have the latest security implementation. I'll have to let someone more familiar with the newer security structures take over. Wish you luck :) – Tetsujin Apr 6 at 18:01
  • 2
    Also? I'm here for help, not condescension. So maybe skip that part. – Jessifer Brandlefly Apr 6 at 20:40
  • 1
    Jessifer: The Disk Utility images you posted only show the volumes. If you press the ⌘2 key combination, then the drives should appear. Highlight the internal drive, then press the Erase button. – David Anderson Apr 7 at 17:31

You must log in to answer this question.

Browse other questions tagged .